VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Need help with wireless card, VL 5.9 SOHO  (Read 1700 times)

Zoukaila

  • Member
  • *
  • Posts: 2
Need help with wireless card, VL 5.9 SOHO
« on: November 24, 2008, 05:18:31 pm »

Hi,

I've been trying to connect to my wireless router under Vector, however everything I've tried so far has failed. I read the HOWTO hosted on this forum and followed it to the letter, searched for revelant topics, but I'm still unable to make this work. Here are some specs :

Laptop : Compaq Evo N600C
Wireless adapter : D-Link DWL-G630 (PCMCIA)
Router wireless settings : Hidden SSID, WPA Personal, TKIP encryption

I did the exact same procedure described in the HOWTO under SLAX, and it worked instantly, using the command wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -B
Under Vector (and with the same wpa_supplicant.conf), I get an error with -Dwext, but get no error using -Dndiswrapper... however, it still doesn't work. Even tried to connect via VASM, with the same result. If anybody needs more info to solve this, I'll be glad to provide it.

Thanks!
Logged

raymac46

  • Member
  • *
  • Posts: 32
Re: Need help with wireless card, VL 5.9 SOHO
« Reply #1 on: November 24, 2008, 05:27:31 pm »

I suspect you may have the same problem i had with ath5K (the new Madwifi FOSS driver module). It doesn't work with certain Atheros wifi cards. The way around it is to blacklist ath5K and download, build and install the legacy 0.9.4 madwifi driver.
There's a thread a bit further down on it.
Logged

Zoukaila

  • Member
  • *
  • Posts: 2
Re: Need help with wireless card, VL 5.9 SOHO
« Reply #2 on: November 24, 2008, 06:06:09 pm »

I suspect you may have the same problem i had with ath5K (the new Madwifi FOSS driver module). It doesn't work with certain Atheros wifi cards. The way around it is to blacklist ath5K and download, build and install the legacy 0.9.4 madwifi driver.
There's a thread a bit further down on it.

Ok... blacklisted ath5k by adding it to /etc/modprobe.d/blacklist , installed madwifi 0.9.4 , did modprobe ath_pci , added alias wlan0 ath_pci in /etc/modprobe.conf , all without errors.
But when I use wpa_supplicant with -Dwext I get the same error as before : "ioctl[SIOCSIWAUTH]: Operation not supported". Any ideas?
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: Need help with wireless card, VL 5.9 SOHO
« Reply #3 on: November 25, 2008, 07:47:23 am »

pls provide your lspci and lsmod output...
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Need help with wireless card, VL 5.9 SOHO
« Reply #4 on: November 25, 2008, 12:35:55 pm »

Do you know if your device name changed from wlan0 to ath0?  If so then perhaps you simply need to adjust your wpa_supplicant command with the new device name.  'ifconfig -a' and/or 'iwconfig' should help with the correct device name.
Logged