VectorLinux
April 19, 2014, 12:59:42 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Hplip, updated driver on VL6rc3- "printer queue setup failed"  (Read 1861 times)
pevsner
Member
*
Posts: 94


« on: January 17, 2009, 08:43:08 am »

HP printer, hplip included VL6rc3 is 2.8.4 which unfortunately is the only version that doesn't include A3 printing for my HP1220c printer.
I updated to the latest 2.12, but have the "printer queue setup failed" warning. So found a hack which is run "LC_ALL=$LANG.UTF8 hp-toolbox" in terminal - works fine. Is there a way to include this setting in a config file somewhere so I can forget about it and allow to run toolbox normally.
Also I havent been able to get the HP plugin to work with VL6.
Suggestions appreciated.

Below is a comment re above I found on the net:
Quote
Slackware 12.1/CHANGES_AND_HINTS.TXT
There is a minor problem with the HPLIP and CUPS versions in Slackware 12.1;
hp-toolbox will not work unless LC_ALL is set to a UTF8 locale.
An easy workaround is to start it with "LC_ALL=$LANG.UTF8 hp-toolbox" if
you're not using a UTF8 locale. Also, your user account must be a member
of the "lp" group for hp-toolbox to work properly, and to use the scanner
portion of some (all?) HP print/scan/copy units, you'll need to be a member
of the "lp" group. This is due to the fact that hplip's udev rules set
the device with group "lp" ownership.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!