VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Can't get my wireless card to work  (Read 3061 times)

pfscpengler

  • Member
  • *
  • Posts: 1
Can't get my wireless card to work
« on: December 06, 2008, 10:08:36 am »

I just installed VL5.9 Light on an older thinkpad (p3-450, 128mb ram).  It works fine, but I can't get my pc card wireless adapter to work.  It's a Linksys WPG54Gv3.  When it's inserted, and I run the wireless setup, it's detected, but once I enter my SSID and password it invariably says "could not obtain an address for eth0".  I tried disabling the password on the wireless network, but it still gives the same error.  With windows installed on the same laptop, this wireless card was able to work on this network.

What can I do to further diagnose my problem?
Logged

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: Can't get my wireless card to work
« Reply #1 on: December 06, 2008, 10:15:28 am »

pls provide your ifconfig -a as root....might post the output of lspci and lsmod too...
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Can't get my wireless card to work
« Reply #2 on: December 06, 2008, 10:30:30 am »

Perhaps your network is static and you simply need to assign an IP address; is this possible or is your network dhcp for sure?

ifconfig -a and iwconfig may also prove to be useful.
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Can't get my wireless card to work
« Reply #3 on: December 06, 2008, 01:29:36 pm »

Perhaps your card name is WPC54g v3

If that is correct that is a broadcom chipset which just needs
firmware installed. Here is a good tutorial:

WPG54Gv3

HTH

Bigpaws
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Can't get my wireless card to work
« Reply #4 on: December 06, 2008, 05:41:41 pm »

Perhaps your card name is WPC54g v3

If that is correct that is a broadcom chipset which just needs
firmware installed. Here is a good tutorial:

WPG54Gv3

HTH

Bigpaws

Bigpaws, looks like the link you posted is no good.  Have you got the correct one handy?
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: Can't get my wireless card to work
« Reply #5 on: December 06, 2008, 05:58:45 pm »

Logged