Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: SD card fails to mount in VL5.9 SOHO  (Read 3663 times)


  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
SD card fails to mount in VL5.9 SOHO
« on: December 03, 2008, 11:01:50 am »

I have a SanDisk 2GB SD card, have had it for some time, it has never worked properly under VL, but works fine in WindowsXP. I have also tried it with Ubuntu and it worked ok. I have reformated the card a number of times but it makes no difference. /var/log/messages shows these errors on insertion of the card:

Dec  3 10:28:06 scorpion kernel: sd 4:0:0:0: [sda] Device not ready: <6>: Sense Key : 0x2 [current]
Dec  3 10:28:06 scorpion kernel: : <<vendor>> ASC=0xff ASCQ=0xffASC=0xff <<vendor>> ASCQ=0xff

It tries about 10 times then gives up (using HAL or vl-hot makes no difference). Another SanDisk 4GB SD card I have works fine. Seems a bit strange that it will be detected in another OS and work fine. Any ideas why this might be the case?
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll


  • Member
  • *
  • Posts: 66
Re: SD card fails to mount in VL5.9 SOHO
« Reply #1 on: December 08, 2008, 06:17:21 pm »

I have a 1.0 Gig eFilm Delkin Devices SD card which also doesn't read.

I use a Secure Digital Card Reader (CR_v7_ud) with the SD card and it works on both my Xp laptop and W2K desktop.

The light blinks on the reader as if something is trying to read it but nothing ever mounts.

I don't know if this extra info helps but whatever happens Lagagnon is first in the cue for help. ;-)
Strange women lying in ponds distributing swords is no basis for a system of government.