VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: updating question  (Read 1682 times)

Monty67

  • Member
  • *
  • Posts: 66
updating question
« on: December 08, 2008, 06:10:34 pm »

I apologize ahead of time if I'm just brain dead.

I went to update Firefox and ran into this:
-------------------
Excluding firefox due to dependency failure

firefox: Depends: glib2 >= 2.16.6-i586-1vl59
-----------------------

I'm running 5.9 SOHO

I then noticed that glspt is telling me that I have this version installed:

Installed: 3.0.1-i586-1vl60

But I thought I wanted:
3.0.4-i586-1vl59

Are you sitting down? Good because here come the dumb questions.

1. How do I get the 5.9 version of FF3.0.4?
2. How did I get the 6.0 version in the first place? After installing 5.9 SOHO I went and got FF for what I thought was for 5.9. I don't have any 6.0 deps listed in gslapt.   
3. How do I get myself out of this mess? ;-)

And it's ok to laugh at me because I have a 3month old son so maybe it's just a lack of sleep thing.  ;D


Logged
Strange women lying in ponds distributing swords is no basis for a system of government.

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Re: updating question
« Reply #1 on: December 09, 2008, 05:22:26 am »

 ;D Its not your problem. The version of glib2 that I was running when I built Firefox 3.0.4 for VL 5.9 seems to have vanished. I've rebuilt Firefox against an earlier glib2 version (which is in the 5.9 repo). It should be available soon - depends on when Caitlyn next does some repo maintenance. Keep an eye open for an announcement in the packages area.

As to how you had a 6.0 version installed, that I can't answer at all..........

paul.
Logged

Monty67

  • Member
  • *
  • Posts: 66
Re: updating question
« Reply #2 on: December 09, 2008, 06:02:35 pm »

 :o

It's not??? Cool. In that case thanks for your help and I will probably uninstall the whole thing and just install the new 5.9 3.0.4 version.

later
Logged
Strange women lying in ponds distributing swords is no basis for a system of government.