VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Mixed up colors in X(fce)  (Read 1861 times)

Zsub

  • Member
  • *
  • Posts: 2
Mixed up colors in X(fce)
« on: December 12, 2008, 02:43:50 pm »

Hey,

Just joined, installed Vector Linux 5.9 GOLD on a Toshiba Tecra 8000. It took some fiddling with settings to get X to output the right resolution (800x600) but now that it does, colors are mixed up. Green displays as purple, and blue as green... Has anyone got any idea as to what I might be doing wrong?

(I re-read my own post and though: yes, right, if I were the expert I'd flame the f- out of myself for not providing any more details. Unfortunately I really don't know what you'd need, sorry...)

Well, did some more testing. I started with just plainly trashing xorg.conf, which seemed to fix it. At least my login screen defaulted to 800x600 with proper colors. However, as xfce loads up it gets all weird after 'loading desktop settings'. Weird as in: pink. There's a pink hue all over the screen and that's not an improvement over the previous situation :P

After some more *cough* careful testing (i.e. renaming the ~/.config dir) I just get normal colors. So I am going to gradually place back files to see which one creates the error. I am wondering how I get my Terminal to display hidden files if I ls? Also: diff doesn't show colors, I thought it did that? Oh, and is it enough to just init 3 and then init 5 to test if a file in .config makes a difference? Rebooting takes ages...

Right. I found the problem. It was in one of xfce's config files. In ~/.config/xfce4/mcs_settings/display.xml to be precise. It contained a gamma correction value that was way off. Renaming that file solved my problem. Another possible solution is to set the values XDisplay/bgamma, XDisplay/ggamma and XDisplay/rgamma all to 100.
« Last Edit: December 12, 2008, 04:45:23 pm by Zsub »
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1871
Re: Mixed up colors in X(fce)
« Reply #1 on: December 12, 2008, 05:25:43 pm »

Impressive troubleshooting.

Complaints about hue are very rare. The question you asked about
hidden files. ls -la will display all files.

Bigpaws
Logged

Zsub

  • Member
  • *
  • Posts: 2
Re: Mixed up colors in X(fce)
« Reply #2 on: December 18, 2008, 05:52:15 am »

Thanks for the answer! (though I am late in thanking you :$ )
Logged