VectorLinux
July 30, 2014, 09:10:28 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 3Com, PCMCIA, will not connect??- SOLVED!!  (Read 1442 times)
longlivelinux
Member
*
Posts: 8


« on: December 14, 2008, 01:33:29 pm »

To save a bit of time, I am posting my results first, and having researched..found no clue...The only ting I may need to chg is going to swap to HAL.

Code:
root:# lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (AGP disabled) (rev 02)
00:02.0 VGA compatible controller: Trident Microsystems Cyber 9397 (rev f3)
00:04.0 Multimedia video controller: C-Cube Microsystems Unknown device 6120
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:0a.0 CardBus bridge: Cirrus Logic PD 6832 PCMCIA/CardBus Ctrlr (rev c1)
00:0a.1 CardBus bridge: Cirrus Logic PD 6832 PCMCIA/CardBus Ctrlr (rev c1)
01:00.0 Ethernet controller: 3Com Corporation 3c575 Megahertz 10/100 LAN CardBus [Boomerang]

Code:
root:# lsmod
Module                  Size  Used by
nf_nat_irc              3072  0
nf_conntrack_irc        6424  1 nf_nat_irc
nf_nat_ftp              3712  0
nf_conntrack_ftp        9088  1 nf_nat_ftp
iptable_nat             7044  0
nf_nat                 16684  3 nf_nat_irc,nf_nat_ftp,iptable_nat
nf_conntrack_ipv4      14860  2 iptable_nat
nf_conntrack           53896  7 nf_nat_irc,nf_conntrack_irc,nf_nat_ftp,nf_conntrack_ftp,iptable_nat,nf_nat,nf_conntrack_ipv4
nfnetlink               5400  3 nf_nat,nf_conntrack_ipv4,nf_conntrack
iptable_filter          3328  0
ip_tables              11236  2 iptable_nat,iptable_filter
x_tables               12548  2 iptable_nat,ip_tables
apm                    19160  2
freq_table              4768  0
snd_opl3sa2            17644  3
snd_opl3_lib            9600  1 snd_opl3sa2
snd_hwdep               7812  1 snd_opl3_lib
snd_cs4231_lib         22016  1 snd_opl3sa2
snd_mpu401_uart         7808  1 snd_opl3sa2
snd_rawmidi            20128  1 snd_mpu401_uart
snd_seq_dummy           3716  0
snd_seq_oss            32128  0
snd_seq_midi_event      7168  1 snd_seq_oss
snd_seq                48720  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7692  5 snd_opl3_lib,snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            38048  0
snd_pcm                69764  3 snd_cs4231_lib,snd_pcm_oss
snd_timer              19972  4 snd_opl3_lib,snd_cs4231_lib,snd_seq,snd_pcm
snd_page_alloc          8712  2 snd_cs4231_lib,snd_pcm
snd_mixer_oss          15232  1 snd_pcm_oss
snd                    45796  19 snd_opl3sa2,snd_opl3_lib,snd_hwdep,snd_cs4231_lib,snd_mpu401_uart,snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss
soundcore               7008  1 snd
3c59x                  40232  0
mii                     5504  1 3c59x
serio_raw               6276  0
i2c_piix4               8332  0
i2c_core               20992  1 i2c_piix4
evdev                   8704  0
joydev                  9152  0

Code:
root:# lspcmcia
Socket 0 Bridge:        [yenta_cardbus]         (bus ID: 0000:00:0a.0)
  CardBus card -- see "lspci" for more information
Socket 1 Bridge:        [yenta_cardbus]         (bus ID: 0000:00:0a.1)

Code:
root:# ifconfig
lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:868 errors:0 dropped:0 overruns:0 frame:0
          TX packets:868 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:46316 (45.2 KiB)  TX bytes:46316 (45.2 KiB)
« Last Edit: December 14, 2008, 02:50:42 pm by longlivelinux » Logged
longlivelinux
Member
*
Posts: 8


« Reply #1 on: December 14, 2008, 01:35:21 pm »

Code:
root:# mii-tool eth0
eth0: negotiated 100baseTx-FD, link ok

Code:
root:# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:60:08:B7:F5:51 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:10 Base address:0x1000

Code:
root:# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Current message level: 0x00000001 (1)
        Link detected: yes

Thats what I done thus far....It  is an older Gateway(sorry) laptop...  Smiley

Anyone with ideas on why card is not showing/working properly?? Thanks in advance...
« Last Edit: December 14, 2008, 02:17:05 pm by longlivelinux » Logged
longlivelinux
Member
*
Posts: 8


« Reply #2 on: December 14, 2008, 02:51:05 pm »

swapped to HAL..all is well...!!
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!