VectorLinux
October 30, 2014, 08:29:20 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Vector and GeexBox and NFS oh my  (Read 1099 times)
Monty67
Member
*
Posts: 66



« on: December 16, 2008, 08:47:37 am »

Hello all

Here is what I want to do and before I ask, I understand that many of you may not use or even care about GeeXBox. But I'm hoping that
people with more NFS experience (not hard) then I can help out.

I want the GeexBox to use NFS to see a shared folder on my VectorLinux 5.9 machine so I can just stream my videos across our network.
I used the GeexBox custom iso builder and added in the mnt points and such. I originally created the share using KDE on my VL machine and when GeeXBox runs it can see it but it doesn't show any of the contents.

I've read http://forum.vectorlinux.com/index.php?topic=669.0 and this http://nfs.sourceforge.net/nfs-howto/ar01s04.html#nfs_boot_time but neither of them help me make the connection. The VL forum one wants me to pre-assign a bunch of stuff but that machine has no HDD. It's a liveCd setup that either uses USB sticks (for now) but eventually when I figure this out, the LAN.

While searching around I noticed (mount -f) that the VIDEO folder is not listed. Shouldn't it be mounted so another pc / device can read from it?
If so how? Am I to assume that KDE does not take care of all my NFS needs and some of it should be done by hand? If so which steps?

Either way thank you for whatever help you can give me.

thanks
Logged

Strange women lying in ponds distributing swords is no basis for a system of government.
newt
Vectorian
****
Posts: 1132



« Reply #1 on: December 16, 2008, 11:35:48 am »

You say your gbox machine "sees" your VL shared directories, but does not list the contents.  Perhaps it's a permissions issue?  Perhaps gbox will only list files which it can 'handle'?  Perhaps gbox (transparently) attempts to log into your VL machine but passes incorrect user credentials, and thus cannot list the contents (far-fetched? probably)?

I'm taking shots in the dark; most likely it's some other issue I'm overlooking.  To have a better idea of what's going on I would probably need to attempt the same setup as you.  If I get around to trying I'll certainly see if I can help out a bit more.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!