VectorLinux
August 21, 2014, 01:46:25 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Has anyone installed gnucash?  (Read 4491 times)
StrayBit
Vectorite
***
Posts: 373



« on: December 17, 2008, 09:08:07 am »

Attempting to install gnucash-2.2.7 in VL5.9 standard
Quote
vector://home/public/Downloads/actg/gnucash-2.2.7
root:# ./configure
...
checking for guile... /usr/bin/guile
checking for guile - 1.6.0 <= version < 99.99.99... yes: 1.8.0
checking for guile - 1.8.0 <= version < 99.99.99... yes: 1.8.0
checking for SLIB support... /usr/bin/guile configure: error:

   Cannot find SLIB.  Are you sure you have it installed?
   See http://bugzilla.gnome.org/show_bug.cgi?id=347922
   and http://bugzilla.gnome.org/show_bug.cgi?id=483631
The links indicated were extremely confusing to me.

Searching configure script: it seems that guile1.8 does NOT have require.scm - even after update in gslapt.

PS:  Suggestions on other double-entry accounting programs are also solicited.
Logged

Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0
MikeCindi
Tester
Vectorian
****
Posts: 1071


« Reply #1 on: December 17, 2008, 10:28:36 am »

gnucash is in the repos but not updated to the lastest (which just came out a few days ago). The docs are also available as a separate install but I couldn't get the one in the repo to actually install the docs. I haven't tried to build the latest gnucash (2.2.Cool. BTW, I'm using VL6 std b2.4 vs. 5.9.
Logged

The plans of the diligent lead to profit...Pro. 21:5
VL64 7.1b3                                     RLU 486143
uelsk8s
Administrator
Vectorian
*****
Posts: 2504



« Reply #2 on: December 17, 2008, 11:06:04 am »

I found this: http://bugzilla.gnome.org/show_bug.cgi?id=347922
 
Logged
Lyn
Vectorian
****
Posts: 650



« Reply #3 on: December 17, 2008, 02:20:12 pm »

I installed it in the latest Vector 6 beta, and it doesn't launch - reports an error. 

lyn:$ gnucash
gnc.bin-Message: main: binreloc relocation support was disabled at configure time.

ERROR: In procedure open-file:
ERROR: No such file or directory: "/usr/lib/slib/mklibcat"
Logged
StrayBit
Vectorite
***
Posts: 373



« Reply #4 on: December 17, 2008, 03:09:17 pm »

Which repo did you find it in?  If I have http://vectorlinux/osuosl.org/veclinux5.9/packages, extra, and patches, I only list gnuchess and gnumeric, Gnupk, gnupg2, and several gnutls are also added to the list.
Logged

Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0
MikeCindi
Tester
Vectorian
****
Posts: 1071


« Reply #5 on: December 17, 2008, 03:32:26 pm »

It's probably in the "testing" repo.

@Lyn: I got the same then ran it as root from the CLI and it would then start as a user.
Logged

The plans of the diligent lead to profit...Pro. 21:5
VL64 7.1b3                                     RLU 486143
Lyn
Vectorian
****
Posts: 650



« Reply #6 on: December 18, 2008, 02:00:59 am »

Which repo did you find it in?  If I have http://vectorlinux/osuosl.org/veclinux5.9/packages, extra, and patches, I only list gnuchess and gnumeric, Gnupk, gnupg2, and several gnutls are also added to the list.

The repos that came with VL 6 beta 2
Logged
Hacker John
Member
*
Posts: 21


« Reply #7 on: October 16, 2009, 08:13:35 am »

I've tried installing version 2.2.9 from source.  Configure stopped with the message that GLIB 2.6 wasn't present.  I tried to install GLIB 2.6 from source and make crapped out with errors.  I seemed to successfully install GLIB 2.6.5 (well, configure, make and make install all ran) but when I try configure with Gnucash, it still tells me that GLIB 2.6 isn't installed.

Am I going to have to install the Gnome desktop to get it working?
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!