VectorLinux
September 16, 2014, 05:07:28 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: SOLVED: wireless works but wep doesn't ?!?  (Read 2259 times)
bad_gui
Member
*
Posts: 61


« on: December 17, 2008, 06:14:22 pm »

I changed my internet service to Verizon Fios and they require their own OEM wireless router.

At first I tried to switch off its wireless and have my trusty Linksys WRT54G with the hyperWRT
flashed firmware get an IP address from the Linksys router and serve as the wireless connection
for my house.  I was unable to get the Verizon and Linksys routers to cooperate.

The weird thing is that my linux box can connect to the Verizon router when WEP is off but not
when it is on (currently I only have a 64bit hex password).  I've re-checked the password and
also entered the hex key in the plaintext format s:  to no avail.

Here is the shell script I use for testing purposes.  It lets me bring down the device and bring it
up with altered settings.

Code:
ifconfig wlan0 down
modprobe -r ndiswrapper
sleep 2
modprobe ndiswrapper
sleep 2
ifconfig wlan0 up
#ifconfig wlan0 up 192.168.1.99
sleep 2
#iwconfig wlan0 mode Managed essid "EGDT0" nick "desktop" channel 11 rate auto key 1F9014E95E
iwconfig wlan0 mode Managed essid "EGDT0" nick "desktop" channel 11 rate auto
sleep 2
dhcpcd wlan0
#route add default gw 192.168.1.1

The commented out lines are what doesn't work.  I can't get a wep connection and I will eventually set up a
static address because it is supposedly less trouble to connect than when having to negotiate dhcp.

It doesn't recognize the iwconfig nickname because my connection on the router shows up like this:

Host:   new-host
IP Address:   192.168.1.4
Subnet Mask:   255.255.255.0
MAC Address:   00:0c:41:6c:3e:09
Network Connection:   Bridge
Lease Type:   Dynamic
Port Forwarding Services:   None
Windows Shared Folders:   \\192.168.1.4\

I should add that my wife's Windows XP laptop connects flawlessly with WEP and my work assigned Windows XP
laptop has to try three times before it can successfully connect with WEP.  I've tried the three times trick with linux
without success.

Any ideas?  I used to have the tcpdump utility in VL3 but I don't see it in VL5.9.  is it somewhere in the downloads
but I am not finding it?

Oops!.  In my haste to post my problem I didn't search the forum properly for WEP connections problems.  I found the answer
in a posting in the networking forum (which is where this belongs).
iwconfig key open XXXXXXXX  fixed the connection problem for VL5.9.  It seems routers have different preferences for
how the wep key is transmitted.  When I used iwconfig key restricted XXXXXX it was unable to connect.   Users will have to
try both and see which works.

I don't know about my windowsXP laptop connection problem but I mostly use my VL5.9 desktop at home anyway.
« Last Edit: December 17, 2008, 08:16:22 pm by bad_gui » Logged
bad_gui
Member
*
Posts: 61


« Reply #1 on: December 21, 2008, 10:56:25 am »

I had to modify the default scripts to have my wireless connection come up automatically.

My router REQUIRES that I use iwconfig key open s:XXXXXXXX and I haven't found a
setting on the router that will let me just use key s:XXXXXXX without the "open".

I changed the /etc/rc.d/rc.wireless script to add a new variable $key_opt to take the options
for the iwconfig key command (see man iwonfig for all of the options for key)

Code:
        if [ -n "$KEY" ] ; then
                echo "$0:  $IWCOMMAND key $KEY_OPT ************" | $LOGGER
                $IWCOMMAND key $KEY_OPT $KEY
        fi

and the corresponding essid.conf file is "/etc/wireless/EGDT0.essid.conf"

Code:
INFO=""
# ESSID (extended network name) : My Network, any
ESSID="EGDT0"
# NWID/Domain (cell identifier) : 89AB, 100, off
NWID=""
# Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
MODE="Managed"
# Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
FREQ=""
CHANNEL="11"
# Sensitivity (cell size + roaming speed) : 1, 2, 3 ; -70 (dBm)
SENS=""
# Bit rate : auto, 1M, 11M
RATE="auto"
# Encryption key : 4567-89AB-CD, s:password
KEY="s:XXXXXXXX"
KEY_OPT="open"
# RTS threshold : off, 500
RTS="2304"
# Fragmentation threshold : off, 1000
FRAG="2304"
# Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
IWCONFIG=""
# iwspy parameters : + 01:23:45:67:89:AB
IWSPY=""
# iwpriv parameters : set_port 2, set_histo 50 60
IWPRIV=""
# WPA parameters: yes to use wpa_supplicant
WPA=""
# Location of paramters for wpa_supplicant
WPACONF=""

I live in a crowded neighborhood and there are many interfering wireless routers on channels
1, 6 and 11 so I followed the guidelines on the linksys website to change the beacon, RTS and
fragmentation thresholds.  I'm not sure it helps but it doesn't seem to hurt.  I also changed these
on the router because it seems the settings only apply to the device and not the connection.


http://www1.linksys.com/support/troubleshoot/wireless/access_point_config/advanced_settings.html



The only thing now is that the stdout from this is so slow that it interferes with my login prompt when
I start up my machine.  I need to see how to slow down the appearance of the login prompt.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!