Please support VectorLinux!

Author Topic: HP Officejet 6310 and hplip Help - SOLVED  (Read 4134 times)

Martin109

  • Vectorite
  • ***
  • Posts: 290
HP Officejet 6310 and hplip Help - SOLVED
« on: December 30, 2008, 01:43:48 am »
I've acquired an HP Officejet 6310, and am pleased to note that it should work with Linux.

I have downloaded hplip-2.8.12.tar.gz.  However, I note from Gslapt Package Manager that there is already a version of hplip installed - it's 1.7.4a-i486-2, and Gslapt mentions version 2.7.12-i586-5vl59 being available but not installed.

Q1.  Should I install the latest version and, if so, how do I do that?

Q2.  Does hplip bypass the CUPS printing system, which I have running my Epson Stylus Photo 890 (not very well)?  Or does hplip have to be incorporated into the CUPS system?

« Last Edit: January 11, 2009, 11:08:40 am by Martin109 »
Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

zaurus

  • Member
  • *
  • Posts: 13
Re: HP Officejet 6310 and hplip Help
« Reply #1 on: January 10, 2009, 10:58:40 pm »
Hi Martin!

I recently bought a HP Officejet 5610 and installation was so simple that I couldn't believe it. It took me 5 minutes in Vector Linux and almost 1 hour in Windows XP.

I plugged in the printer at the USB port and booted into VL. Then go CUPS (Direct browser to 127.0.0.1:630) and install a new printer. For the port I choose 'USB Printer #1' then maker 'HP' and model 'HP Officejet 5600'. After that I could print.

You can try with your installed version first and see if you can find 'Officejet 6310' or 'Officejet 6300' in the model list. If you cannot find it then maybe you upgrade to the newer version.

HPLIP does not bypass CUPS. Printing is still via CUPS, but it uses some drivers from inside HPLIP.

Cheers

Zaurus

Martin109

  • Vectorite
  • ***
  • Posts: 290
Re: HP Officejet 6310 and hplip Help
« Reply #2 on: January 11, 2009, 11:08:18 am »
Thanks, zaurus, that's worked nicely! :)
Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

triyanto

  • Member
  • *
  • Posts: 10
Re: HP Officejet 6310 and hplip Help - SOLVED
« Reply #3 on: March 18, 2009, 10:02:33 pm »
I have HP D1360 printer for my VL STD 5.9. It is detected by VL, but when I try to run "print test page" there is nothing appear on the paper. The printer seems to be work well. The paper run smoothly into it. But. like what I've said, notihng appears on the paper. While, the printer works well in Win XP. Any ideas friends?

Martin109

  • Vectorite
  • ***
  • Posts: 290
Re: HP Officejet 6310 and hplip Help - SOLVED
« Reply #4 on: March 19, 2009, 05:53:38 am »
Hi triyanto!

You may be better served starting a new thread about your query, as it may get overlooked added to this [SOLVED] query.

HTH
Compaq Armada E500, i686 Pentium III, 512Mb RAM, 3.2 Gb HDD, running Vector Linux 5.9 Standard

Fujitsu Lifebook, i686 Pentium M, 1.7 GHz, 1028Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard

Compaq Evo, i686 Pentium M, 1.4 GHz, 512Mb RAM, 40 Gb HDD, running Vector Linux 6.0 Standard