VectorLinux
October 25, 2014, 03:17:08 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: boot options for swap?  (Read 4095 times)
aixuser01
Member
*
Posts: 86


« on: December 31, 2008, 01:50:51 pm »

I installed vl 5.9 lite on my eee machine. Install was no problem but installer saw the disk as sdc but the kernel booting sees sda, I can get the rootfs with boot option root=/dev/sda1 but is there a way to define the swap partition on the boot line? also once I get this thing running, how do I modify the boot record so I don't have to give command line options?

Thanks!
Logged

Evil Overlord rule 58 My doomsday device will not employ a large red digital countdown device unless it is absolutely necessary.  If a countdown device proves to be necessary, the doomsday device will be set to activate when the counter reaches 00:10:00, rather than 00:00:00.
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #1 on: December 31, 2008, 03:29:51 pm »

Try running "vliloconf" and see if it sets up your boot loader correctly.

For the swap partition, edit the appropriate line in /etc/fstab
Logged
aixuser01
Member
*
Posts: 86


« Reply #2 on: January 05, 2009, 12:10:56 pm »

ok, I got the kernel to boot with the root=/dev/sda1 but it only brought up the fs in read mode. had to use root=/dev/sda1 rw to boot. then got a nasty message at boot time about how /root was already mounted rw.

anyway it did boot but could not find the swap partition.
I edited /etc/lilo.conf to change all the references from hdcX to sdaX, then ran lilo to install it.

Edited /etc/fstab again changed hdcX to sdaX rebooted and all was good.

However, I had a problem getting some of the drivers to work ( not discussed here) and booted from the 2.6.22.19 kernel and guess what IT sees hdcX partitions and not sdaX.

Any thoughts?
Logged

Evil Overlord rule 58 My doomsday device will not employ a large red digital countdown device unless it is absolutely necessary.  If a countdown device proves to be necessary, the doomsday device will be set to activate when the counter reaches 00:10:00, rather than 00:00:00.
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #3 on: January 05, 2009, 07:39:06 pm »

5.9 Light comes with two slightly different kernels, "sata" (default) and "ide". You can choose which one when you to use when booting from the CD. To use the IDE kernel to boot your installed system, use "ide root=/dev/sda1 ro".

Try to edit fstab (make a backup first) to reference "hdXX" instead of "sdXX", and boot to the secondary kernel. If it works better than the other, then edit /etc/lilo.conf  to make "2.6.22.19" the default kernel (change the line that says "default = linux"), then run command "lilo" as root.

Logged
aboniup75
Member
*
Posts: 7


« Reply #4 on: September 21, 2009, 05:54:15 am »

I tried changing the timeout to -1 as it says in the default loader.conf and all it does is go to the boot menu options and wait until i press enter to continue.

what Ive done is added a /cf/boot/loader.conf.local file rw-r-r per the advice of the /cf/boot/defaults/loader.conf
in it i have autoboot_delay="-1"

my file i added does work because i can set it to "1" and it continues booting after one second as it should.

has the command changed or is it not working for now?

this is with an embedded 69.1
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!