VectorLinux
August 19, 2014, 10:33:05 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Autoload Modules?  (Read 2627 times)
adamlau
Member
*
Posts: 15


« on: January 03, 2009, 04:08:49 am »

Where do I add the line item
Code:
fuse
...in order to load it into the kernel without having to type in
Code:
modprobe fuse
...everytime I run TrueCrypt (and other programs which request it)?
Logged
bigpaws
Vectorian
****
Posts: 1845


« Reply #1 on: January 03, 2009, 06:47:04 am »

It maybe that fuse is not executable, check permissions on /etc/rc.d/rc.fuse

You can add things to be executed in /etc/rc.d/rc.local

HTH

Bigpaws
« Last Edit: January 03, 2009, 08:00:06 am by bigpaws » Logged
adamlau
Member
*
Posts: 15


« Reply #2 on: January 03, 2009, 03:44:43 pm »

Added the following line:

Code:
/sbin/modprobe fuse

into the following file:

Code:
/etc/rc.d/rc.modules

and all is well now. Though I gather the same line entry into /etc/rc.d/rc.local would have worked as well. However, I just noticed another option through VASMCC > Service > Services for loading the fuse daemon at run level 4. May work as well.
« Last Edit: January 03, 2009, 04:05:20 pm by adamlau » Logged
bigpaws
Vectorian
****
Posts: 1845


« Reply #3 on: January 03, 2009, 05:07:45 pm »

All of the above would have worked.

Bigpaws
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!