VectorLinux
November 27, 2014, 11:09:33 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Upgrading Soho deluxe to Kde 3.5.10  (Read 1487 times)
cmscritic
Member
*
Posts: 1


« on: January 03, 2009, 07:37:16 am »

I'd like to know please why when i do a slapt-get --dist-upgrade, the latest versions of Firefox and KDE are not downloaded? I can see their is a naming difference on firefox but not sure why you guys would not set it so people can update. Also for KDE 3.5.9 -> 3.5.10.. the packages are visible in Gslapt but mark all upgrades does not select anything.

??
Logged
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #1 on: January 03, 2009, 07:59:58 am »

Vector Linux does NOT support --dist-upgrade.  In fact VL warns against ever using that option.  It is known to cause breakage.  It simply is not supposed to work with this distro.  Any results you get that are less than optimal are not surprising at all since it's not expected to work.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
rbistolfi
Packager
Vectorian
****
Posts: 2290


« Reply #2 on: January 03, 2009, 08:47:55 am »

I'd like to know please why when i do a slapt-get --dist-upgrade, the latest versions of Firefox and KDE are not downloaded? I can see their is a naming difference on firefox but not sure why you guys would not set it so people can update. Also for KDE 3.5.9 -> 3.5.10.. the packages are visible in Gslapt but mark all upgrades does not select anything.
??

As Caitlyn pointed, --dist-upgrade is not yet supported. I think you want to try --upgrade, which would install all the updates available. There is a discussion going on in the community about how good or not is doing a slapt-get --upgrade. Some people thinks that all the upgrades are not necessary and that the risk involved in a full system wide update is too high compared with the benefits. Of course, others prefers to have the latest software version available.
In any case, you should get all the critical security patches. Please let us now if slapt-get --upgrade solves your problem (if you go with the full up-to-date thing) or if you find any problems updating any individual package.

Cheers, Rodrigo.
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #3 on: January 03, 2009, 02:46:23 pm »

Rodrigo makes an excellent point.  I've done slapt-get --upgrade religiously going back to VL 5.8.  It has never caused breakage for me other than one package (wifi-radar on VL 5.Cool, and that was when glibc wsa upgraded during a release cycle, something the developers have decided was a mistake.  --upgrade should pull in the KDE packages.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!