VectorLinux
November 22, 2014, 07:23:59 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: AbiWord not working in SOHO 5.91 Deluxe  (Read 3389 times)
TLM
Member
*
Posts: 88


« on: January 05, 2009, 08:34:25 am »

Hello everyone,
I am new to Linux and new to the forum. I recently purchased Vector Linux 5.91 SOHO Deluxe. I have messed with Windows for years, so installing Vector was no problem. My troubles began when I tried to add additional packages that SOHO deluxe did not come with. I will start with Abiword for this post. I downloaded the Abiword package from http://vectorlinux.osuosl.org/veclinux-5.9/packages/x-apps/abiword-2.5.2-i586-1vl59.tlz

I was able to install it, however it will not launch. It will not launch from the menu, and it will not launch from Konsole either. Konsole returns the following errors:

abiword: error while loading shared libraries: libgnomeprintui-2-2.so.0:
cannot open shared object file: No such file or directory

I have already tried ldconfig, as well as finding the abiword exe file by using the whereis command. Finally I learned how to use the lld command to list the dependencies, and the following two libraries appear to be missing:

libgnomeprintui-2-2.so.0 => not found
 libgnomeprint-2-2.so.0 => not found

It was at this point that the paid support personnel referred me to this forum. I cannot find these exact libraries in any of the repositories. Anyone know how to get Abiword up and going on SOHO 5.91 Deluxe?

I am having similiar issues with trying to install gparted, but I will focus on Abiword for now. Any help is appreciated. Please be patient if I do not respond for several hours. I do not have access to the Internet where I work, so I will be checking in before and after work. Thanks!
« Last Edit: January 05, 2009, 08:37:46 am by TLM » Logged

Particle board should be outlawed.
M0E-lnx
Administrator
Vectorian
*****
Posts: 3192



« Reply #1 on: January 05, 2009, 09:39:20 am »

Hi TLM and welcome to the forum
Than you for purchasing the deluxe version.

May I suggest you use gslapt from the vector menu to install additional software rather than manually downloading packages from our repositories.

Using gslapt will ensure that your packages get installed along with their necessary dependancies.

You may remove your manually installed abiword package by doing this in a terminal as root
Code:
removepkg abiword
Then launch gslapt and search for abiword

HTH
Enjoy your stay Wink
Logged

caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #2 on: January 05, 2009, 11:15:01 am »

I want to expand on what MOE_lnx said:  If you download single packages from the repository and install them manually you will almost always get broken results simply because you are missing required dependencies.  The purpose of the package managers, slapt-get at the command line or gslapt in the GUI, is to resolve those dependencies for you and to install or update all the packages you need.  This is similar to all the major Linux distributions out there.

HTH,
Caitlyn
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #3 on: January 05, 2009, 01:43:02 pm »

I'm also a little concerned that you're installing AbiWord 2.5.2.  That was a beta with significant bugs.  AbiWord 2.6.4 is in the repository for VL 5.9.1.  I suspect that your patches repository isn't enabled.  Without it you won't see any of the security patches that your system needs to be secure as well as other bigfix updates to core packages.

You can enable patches by editing your /etc/slapt-get/slapt-getrc file or from the GUI in gslapt:

Click on the Edit menu
Click on Preferences
Click on the Sources tab
Make sure the box next to patches is selected

In general you should always have packages, extra, and patches enabled.  Testing and unstable should be disabled.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
TLM
Member
*
Posts: 88


« Reply #4 on: January 05, 2009, 08:48:56 pm »

Thank you everyone. I will try the suggestions and see what happens. I might add to caitlyn that the reason I tried Abiword 2.52 is because that is what the paid support suggested. I did see that a newer version was available, however since I am new to the Linux scene, I was trusting what paid support recommended. Also, the install I done was on a laptop, and Vector does not recognize the LAN adapter, however I have several PCMCIA LAN adapters to try, and hopefully it will recognize one of them. Then I can go online with it and use the gslapt features. Thanks everyone! I've tried several distros, and settled on this one due to features and speed.
Logged

Particle board should be outlawed.
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #5 on: January 05, 2009, 09:13:00 pm »

Almost all NICs are supported by Linux and, by extension, Vector Linux.  If you want we can help you troubleshoot the problem.  I'd suggest starting a new thread in the Networking section of the forum.  Let us know what type of NIC you have and someone will walk you through the steps to find out why it isn't recognized.

I'm a little concerned about the answers you got from paid support as well.  I know who to talk to about that and I will follow up in an appropriate way.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
TLM
Member
*
Posts: 88


« Reply #6 on: January 05, 2009, 10:25:24 pm »

Yea! Just popped in an old Linksys Wireless card and am now online using gslapt. Will post results later. Thanks again everyone Cheesy
Logged

Particle board should be outlawed.
TLM
Member
*
Posts: 88


« Reply #7 on: January 05, 2009, 10:52:45 pm »

Gslapt has successfully installed all of the additional apps that I wanted Grin. Now I am wondering, like caitlyn, why the paid support did not tell me to do that in the 1st place? But all is well that ends well. This was an experimental install on a 6 gig HD on an old WinBook J1 (Green 720) laptop. Now that I kind of know my way around, I am going to add a hard drive to my desktop and keep Windows on one drive and Vector on the other. I will just change the boot order to boot into whichever OS I want. I will be using Vector almost exclusively for Internet and Email. More later as I learn. I found Vector after I played around with BackTrack, and started hunting around for other Slackware based distros. This is by far the best Linux I have ever used. I can't say enough about it! Thanks so much for all the help. I'll probably be back.
Logged

Particle board should be outlawed.
metvas
Vectorite
***
Posts: 311


« Reply #8 on: January 06, 2009, 06:49:58 pm »

Hello TLM

Did you purchase the hard disks or high speed download? As for paid help who was it you talked to? Happy to see your problems have been resolved.
thxs
metvas
Logged

Knowledge is Power, share it.
Be the change you want to see in the World
TLM
Member
*
Posts: 88


« Reply #9 on: January 06, 2009, 07:25:52 pm »

Hi metvas,
I ordered the high speed download. I will not name the paid help that I spoke to, since I do not want them to get into trouble. Although they did kind of go the round about way in trying to help me install additional software, they also made me aware of terminal functions that I was not aware of. Things like ldconfig and the whereis commands. They additionally sent me links to suggested reading, where I learned about the lld command. It was then that I was able to pinpoint the two missing libraries that I needed for Abiword. After I reported this to the paid help, they suggested that I bring the issue to this forum. So in a very round about way, the paid help person that attempted to help me actually ended up doing so! But I do agree that all paid support personnel need to be advised to inform people about gslapt when it comes to installing additional apps.
Logged

Particle board should be outlawed.
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #10 on: January 06, 2009, 10:02:17 pm »

Metvas is the person I intended to PM Smiley  I'm glad he's already on top of things. 
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!