Please support VectorLinux!

Author Topic: Timidity++ in 6.0 RC3  (Read 3956 times)


  • Member
  • *
  • Posts: 28
Timidity++ in 6.0 RC3
« on: January 22, 2009, 09:55:30 pm »
Can someone tell me how to install timidity++ in Vector 6.0 RC3, I tried to use vpackager and dl the package from Sourceforge but it would not install.


The Headacher

  • Louder than you
  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1559
  • I like the bass to go BOOM!
    • Multimedia on VL (work in progress)
Re: Timidity++ in 6.0 RC3
« Reply #1 on: January 23, 2009, 12:23:38 am »
I'm not sure, but I'd think vpackager would give some errors? If you post them here, it might be easier to help.
Most music on my soundcloud page was arranged in programs running on VL.


  • Packager
  • Member
  • ****
  • Posts: 83
Re: Timidity++ in 6.0 RC3
« Reply #2 on: January 23, 2009, 04:09:38 am »
A quick FYI, the tarball at Sourceforge is very much out of date.  The latest version with lots of very useful patches is in cvs.

Am going to see if I can build a copy of this program myself when I have some free time.  You do need a bunch of settings on the configure line.  I believe I used the following last time I built it on Linux:
 ./configure --enable-interface=ncurses,motif,emacs,vt100,xaw,gtk --enable-spectogram --enable-wrd
The trickiest part is getting the configuration files in the proper place.  If you need help with creating configuration files and finding some basic sound fonts, check out:
It is a Windows oriented site, but the configuration files and soundfonts should work pretty much the same across both platforms, just watch the direction of your directory slashes in your configuration files.

Also, check out the Freepats project if you want the best in Open Source soundfonts to recreate your midi instrument sounds:
« Last Edit: January 23, 2009, 05:03:44 am by lm8 »


  • Member
  • *
  • Posts: 28
Re: Timidity++ in 6.0 RC3
« Reply #3 on: January 23, 2009, 11:18:07 am »
I tried to connect to the cvs server using the cmd cvs -d login

cvs -d co timidity

pressed return but it refuses to connect. Am I issuing the proper cmd? I'm going by what's indicated on the sourceforge website to access cvs