Author Topic: Help! Vector Linux network set up  (Read 8215 times)


  • Member
  • *
  • Posts: 3
    • Dutton Designs
Help! Vector Linux network set up
« on: January 15, 2009, 04:09:33 pm »
Hello everyone!  I am a bit of a newbie to VL but am liking it so far!  Here's what happened:

Installed, set up went fine.  The only thing is, it never has worked with the internet right away.  I would always have to go the the Control Center, choose Internet & Networking.  When I clicked on that, it would always say my 'Network Platform was not found' (or something along those lines) and I would have to choose a default platform.  Now, being new to Vector, all I knew was that it was a version of slackware (am I correct?) so I would choose a Slackware version from the list.  Once I chose that, it would show my eth0 settings.  I would have to click the 'Routes' tab and change the IP address listed there (because my router's IP is which is my default gateway.

Everytime I turned on the computer, I would have to do this.  Today, I had to do the same thing.  Now, remember how I told you that when I would click on 'Internet & Networking' in the control center it would ask me to choose a platform?  Well, there was a check box there saying 'Don't ask again'...I figured, since I chose the same one each time, I could check this box and maybe it would solve my problem!  WRONG!

Needless to say, now I can't get the comp on the web at all!  In the 'Routes' tab, when I go to change the gateway from '' to '' and click apply.  It looks like it changed it...but it doesn't.  I will change it, click apply, close the window, and then go back there, it changed right back!  It won't stay!

Now, I am hooked to a router.  I've tried changing it as my root user as well and it does the same thing.  Any help you guys can give me would be greatly appreciated!



  • Member
  • *
  • Posts: 3
    • Dutton Designs
Re: Help! Vector Linux network set up
« Reply #1 on: January 15, 2009, 04:56:07 pm »
I do want to add that I have tried editing the default gateway line in the  '' (i think; can't recall cuz i'm not on that computer right now) file in /etc/sysconf/network-scripts/ and that didn't change anything.


  • Administrator
  • Vectorian
  • *****
  • Posts: 1906
Re: Help! Vector Linux network set up
« Reply #2 on: January 15, 2009, 05:39:55 pm »
In a console (terminal) you can as root type:


That will help you setup the network.

To really troubleshoot this more information is needed.

1.  Name and model of the NIC card
2.  The output of lsmod         You can type lsmod > lsmod That will make a file called lsmod with all the
     output  which you can paste
3.   As root in a terminal type: ifconfig (you are looking for a reference to eth0) if it there good if not
      respond here

If you include the above information then we should be able to get you going.



  • Member
  • *
  • Posts: 3
    • Dutton Designs
Re: Help! Vector Linux network set up
« Reply #3 on: January 16, 2009, 07:03:10 am »

Thanks for your help.

I honestly have no idea what kind of NIC card the machine has.  It's just an old celeron machine I snagged off of a friend and am playing around with.  Below are the results from lsmod:

root:# lsmod
Module                  Size  Used by
i915                   22144  1
drm                    71324  2 i915
iptable_nat             7172  0
nf_nat                 16556  1 iptable_nat
nf_conntrack_ipv4      14860  2 iptable_nat
nf_conntrack           53128  3 iptable_nat,nf_nat,nf_conntrack_ipv4
nfnetlink               6168  3 nf_nat,nf_conntrack_ipv4,nf_conntrack
iptable_filter          3460  0
ip_tables              12020  2 iptable_nat,iptable_filter
x_tables               12804  2 iptable_nat,ip_tables
cpufreq_conservative     6920  0
cpufreq_ondemand        7308  0
cpufreq_performance     2816  0
cpufreq_powersave       2560  0
p4_clockmod             5412  0
speedstep_lib           5128  1 p4_clockmod
freq_table              4640  2 cpufreq_ondemand,p4_clockmod
sg                     28456  0
fuse                   40724  0
snd_seq_dummy           3980  0
snd_seq_oss            30208  0
snd_seq_midi_event      6912  1 snd_seq_oss
snd_seq                47344  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7308  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            42176  0
snd_mixer_oss          15616  1 snd_pcm_oss
shpchp                 30496  0
pci_hotplug            28752  1 shpchp
snd_intel8x0           30016  1
snd_ac97_codec         92332  1 snd_intel8x0
ac97_bus                3072  1 snd_ac97_codec
snd_pcm                70540  3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer              20744  2 snd_seq,snd_pcm
8139too                24336  0
snd                    44644  11 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
parport_pc             37092  0
i2c_i801                8076  0
pcspkr                  3584  0
soundcore               7264  1 snd
mii                     5888  1 8139too
snd_page_alloc          8712  2 snd_intel8x0,snd_pcm
parport                31560  1 parport_pc
evdev                   9088  0
iTCO_wdt               10032  0
intel_agp              22044  1
i2c_i810                6020  0
i2c_algo_bit            8208  1 i2c_i810
i2c_core               18816  3 i2c_i801,i2c_i810,i2c_algo_bit
agpgart                28748  3 drm,intel_agp
serio_raw               6404  0

If this isn't what you are asking for, sorry!

I ran the netconfig in the terminal and it didn't seem to change anything.



  • Member
  • *
  • Posts: 2
Re: Help! Vector Linux network set up
« Reply #4 on: January 25, 2009, 10:52:30 am »

I had the same problem. Every time i started my computer there was no network. But there was no problem setting it up again using vasm. Next time i rebooted all the same again!

What i found out was that the system did not load mii module and not e100 module (8139too in your case). After i ran vasm network setup those two modules where loaded and the network card worked just fine. So i added two lines to my rc.inet1 file.

modprobe mii
modprobe e100

Now the network working every time i boot my system.


  • Packager
  • Vectorian
  • ****
  • Posts: 3287
  • -- Just being myself --
Re: Help! Vector Linux network set up
« Reply #5 on: January 25, 2009, 04:25:52 pm »
pls provide lspci output...


  • Member
  • *
  • Posts: 2
Re: Help! Vector Linux network set up
« Reply #6 on: January 26, 2009, 11:57:48 am »
Here is my output from lspci:

00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:0a.0 Ethernet controller: Intel Corporation 82557/8/9 Ethernet Pro 100 (rev 05)
00:14.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:14.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:14.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:14.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c)