VectorLinux
October 24, 2014, 10:28:35 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: vpnc install problem?  (Read 1928 times)
bad_gui
Member
*
Posts: 61


« on: February 05, 2009, 07:21:37 pm »

Hi,

Maybe I'm missing something here?

I downloaded the vpnc package from http://www.usit.uio.no/it/hjemmekontor/english/vpn/linuxvpnc.html and
I untarred it.

I ran make with no errors.

Then I use

Quote
root:# checkinstall -L --fstrans=no

checkinstall 1.6.0, Copyright 2002 Felipe Eduardo Sanchez Diaz Duran
           This software is released under the GNU GPL.



********************************************
**** Slackware package creation selected ***
********************************************

This package will be built according to these values:

1 -  Summary: [ vpnc-0.5.3 ]
2 -  Name:    [ vpnc ]
3 -  Version: [ 0.5.3 ]
4 -  Release: [ 1 ]
5 -  License: [ GPL ]
6 -  Group:   [ Applications/System ]
7 -  Architecture: [ i386 ]
8 -  Source location: [ vpnc-0.5.3 ]
9 -  Alternate source location: [  ]
10 - Requires: [  ]

Enter a number to change any of them or press ENTER to continue:

Installing with make install...

========================= Installation results ===========================
install -d /etc/vpnc /usr/local/bin /usr/local/sbin /usr/local/share/man/man1 /usr/local/share/man/man8 /usr/local/share/doc/vpnc
if [ "`uname -s | cut -c-6`" = "CYGWIN" ]; then \
                install vpnc-script-win /etc/vpnc/vpnc-script; \
                install vpnc-script-win.js /etc/vpnc; \
        else \
                install vpnc-script /etc/vpnc; \
        fi
install -m600 vpnc.conf /etc/vpnc/default.conf
install -m755 vpnc-disconnect /usr/local/sbin
install -m755 pcf2vpnc /usr/local/bin
install -m644 vpnc.8 /usr/local/share/man/man8
install -m644 pcf2vpnc.1 /usr/local/share/man/man1
install -m644 cisco-decrypt.1 /usr/local/share/man/man1
install -m644 COPYING /usr/local/share/doc/vpnc
install -m755 vpnc /usr/local/sbin
install -m755 cisco-decrypt /usr/local/bin

======================== Installation successful ==========================

Copying documentation directory...
./
COPYING
ChangeLog
README
TODO
VERSION

Copying files to the temporary directory...OK

Striping ELF binaries and libraries...OK

Compressing man pages...OK

Building file list...OK

Preparing Slackware install directory...OK

Writing package description...OK

Creating package vpnc-0.5.3-i386-1.tlz...
Slackware SLAPT-GET package maker, version 2.1.
Prepending doins script ...
Moving symbolic links to scripts ...
Adding slapt-get dependencies ...
./usr/local/bin/cisco-decrypt:
libgcrypt >= 1.2.4
libgpg-error >= 1.5
./usr/local/bin/pcf2vpnc:
perl >= 5.8.8
./usr/local/sbin/vpnc:
./usr/local/sbin/vpnc-disconnect:
bash >= 3.1.017
./etc/vpnc/vpnc-script:

Creating package vpnc-0.5.3-i386-1.tlz ...

Creating tar file vpnc-0.5.3-i386-1.tar...

./
usr/
usr/doc/
usr/doc/vpnc-0.5.3/
usr/doc/vpnc-0.5.3/COPYING
usr/doc/vpnc-0.5.3/ChangeLog
usr/doc/vpnc-0.5.3/README
usr/doc/vpnc-0.5.3/TODO
usr/doc/vpnc-0.5.3/VERSION
usr/local/
usr/local/bin/
usr/local/bin/cisco-decrypt
usr/local/bin/pcf2vpnc
usr/local/sbin/
usr/local/sbin/vpnc
usr/local/sbin/vpnc-disconnect
usr/local/share/
usr/local/share/doc/
usr/local/share/doc/vpnc/
usr/local/share/doc/vpnc/COPYING
usr/local/share/man/
usr/local/share/man/man1/
usr/local/share/man/man1/pcf2vpnc.1.gz
usr/local/share/man/man1/cisco-decrypt.1.gz
usr/local/share/man/man8/
usr/local/share/man/man8/vpnc.8.gz
etc/
etc/vpnc/
etc/vpnc/default.conf
etc/vpnc/vpnc-script
install/
install/doinst.sh
install/slack-desc
install/slack-required
tar-1.13: vpnc-0.5.3-i386-1.tar is the archive; not dumped

Compressing vpnc-0.5.3-i386-1.tlz ...

Package creation vpnc-0.5.3-i386-1.tlz complete.

OK

NOTE: The package will not be installed.

Erasing temporary files...OK

Writing backup package...OK

Deleting temp dir...OK


**********************************************************************

 Done. The new package has been saved to

 /home/progs/vpnc-0.5.3/vpnc-0.5.3-i386-1.tlz
 You can install it in your system anytime using:

      installpkg vpnc-0.5.3-i386-1.tlz

**********************************************************************

Why do I get the error "package will not be installed?"  Some files are written to the system

:$ ls /usr/local/sbin/vpnc*
/usr/local/sbin/vpnc*  /usr/local/sbin/vpnc-disconnect*


but not others such as the man pages.  In fact the directories are completely empty!

/usr/local/share/man/man1/

What am I doing wrong?
Logged
bad_gui
Member
*
Posts: 61


« Reply #1 on: February 05, 2009, 07:42:46 pm »

 Embarrassed Embarrassed

It has been a while since I have installed something and I forgot to follow the instructions
that were right in front of me

Quote
You can install it in your system anytime using:

installpkg vpnc-0.5.3-i386-1.tlz

It seems that vector has the man pages located in /usr/man/man1 while this install
script is trying to write to /usr/local/share/man/man1 and the man application isn't
looking in the second location even though the files are there:

Quote
# ls /usr/local/share/man/man1         
cisco-decrypt.1.gz  pcf2vpnc.1.gz

# man pcf2vpnc
No manual entry for pcf2vpnc

I guess I can just copy the files from /usr/local/share/man/ to /usr/man/man1

Now I need to figure out the vpnc error when I try to connect

Quote
Enter password for XXXX@XX.X.XX.XX:

which: no ip in (/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/usr/sbin:/bin:/opt/bin:/usr/X11/bin:/usr/local/games:/usr/games:/opt/Adobe/Reader8/bin/:/usr/lib/java/bin:/usr/lib/java/jre/bin:/usr/lib/qt/bin:/opt/seamonkey/bin:/usr/local/sbin:/usr/sbin:/sbin)
« Last Edit: February 05, 2009, 08:03:54 pm by bad_gui » Logged
bad_gui
Member
*
Posts: 61


« Reply #2 on: February 06, 2009, 07:34:15 pm »

VL5.9 doesn't contain an executable for "ip" which other distros appear to have:

http://linux.die.net/man/8/ip

According to this man page:

Quote

History

ip was written by Alexey N. Kuznetsov and added in Linux 2.2.


Anyone know which VL, Slackware etc. package contains this?

« Last Edit: February 06, 2009, 07:38:43 pm by bad_gui » Logged
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #3 on: February 07, 2009, 06:29:09 am »

The commands "ifconfig" and "route" do the same things...
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!