VectorLinux
October 30, 2014, 03:53:09 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: [Solved] Mousepad Saving Locale  (Read 1514 times)
Pita
Vectorian
****
Posts: 1311


« on: January 30, 2009, 06:08:20 pm »

I am just changing from my previous text editor to mousepad since it can display
certain characters correctly. Now if I try to save a file the 'save as' window shows
a bar "Current Locale (ISO-8859-1)". If I then try to save I get: "Can't convert codeset to 'ISO-8859-1'"
and the save window is gone.

In order to save I have to change this Current Locale to UTF-8 in the save window.

How can I make it permanent  UTF-8?

There is a mousepadrc, however, I would not know what to enter.

Thanks & regards
« Last Edit: January 31, 2009, 06:47:18 pm by Pita » Logged
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #1 on: January 30, 2009, 10:34:31 pm »

Change the variable LANG in /etc/profile.d/lang.sh from en_US to en_US.utf8.  That will enable utf8 across the board.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
Pita
Vectorian
****
Posts: 1311


« Reply #2 on: January 31, 2009, 06:46:33 pm »

Thanks! It works.

Regards
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!