VectorLinux
December 18, 2014, 12:11:26 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Opera not working in VL 5.9 Light  (Read 1006 times)
hata_ph
Packager
Vectorian
****
Posts: 3261


-- Just being myself --


« on: January 31, 2009, 04:49:48 am »

Today my opera was not able to open due to below error message...

Quote
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.

From the net it saying it need JRE to be install. But all the while my opera is running fine without JRE but why suddenly I need it?
There is another alternative way is to......

Quote
About libjvm.so and libawt.so: those seem to be java SDK related.
So if (like me) you do not have SDK packages installed, you can ignore those errors or edit opera binary as following :
Code:
## Uncomment the next lines to workaround the "libjvm.so & libawt.so preloaded" error message
#LD_PRELOAD="libjvm.so:libawt.so:${OPERA_LD_PRELOAD}"
#export LD_PRELOAD
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!