VectorLinux
October 24, 2014, 05:03:50 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 090130 AbiWord 2.6.6 & dependencies [VL 6.0]  (Read 1031 times)
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« on: January 29, 2009, 10:17:29 pm »

I've packaged the latest version of AbiWord in four packages for VL 6.0.  This version of AbiWord has dependencies for new versions of goffice, libgsf, and link-grammar, which were previously announced.  It also has new dependencies that prior versions did not have, specifically asio and libshoes, which are listed below.

Package:  abiword-2.6.6-i586-1vl60.tlz
MD5:  c68195b8321225f3e87ad0c741436240
Package Size:  2.24MB
Installed Size:  11.88MB

Sources:  http://vectorlinux.osuosl.org/veclinux-6.0/source/testing/x-apps/abiword

Code:
abiword: abiword (word processing program)
abiword:
abiword: AbiWord is a free word processing program similar to Microsoft® Word.
abiword: It is suitable for a wide variety of word processing tasks.
abiword:
abiword: AbiWord has been created by a worldwide group of volunteers and currently
abiword: supports many languages and operating systems.
abiword:
abiword: License: GNU General Public License, version 2
abiword: Authors: see CREDITS.TXT file
abiword: Website: http://www.abisource.com


Package:  abiword-extras-2.6.6-i586-1vl60.tlz
MD5:  480549ad3b8d4d69b43a880c951b6069
Package Size:  367K
Installed Size:  810K

Sources:  http://vectorlinux.osuosl.org/veclinux-6.0/source/testing/x-apps/abiword-extras

Code:
abiword-extras: abiword-extras (files used by AbiSuite)
abiword-extras:
abiword-extras: This directory tree contains GPL or GPL-compatible files
abiword-extras: used by AbiSuite that are very big and/or that don't change
abiword-extras: very often.
abiword-extras:
abiword-extras:
abiword-extras:
abiword-extras:
abiword-extras: License: GPL & various GPL-compatible
abiword-extras: Website: http://www.abisource.com


Package:  abiword-docs-2.6.6-i586-1vl60.tlz
MD5:  8ba6083afb260dc1ee958c33e517dc08
Package Size:  979K
Installed Size:  2700K

Sources:  http://vectorlinux.osuosl.org/veclinux-6.0/source/testing/x-apps/abiword-docs

Code:
abiword-docs: abiword-docs (Documents for AbiWord)
abiword-docs:
abiword-docs: Documentation and help files for the AbiWord
abiword-docs: word processor.
abiword-docs:
abiword-docs:
abiword-docs:
abiword-docs:
abiword-docs:
abiword-docs:
abiword-docs: Website: http://www.abisource.com


Package:  abiword-plugins-2.6.6-i586-1vl60.tlz
MD5:  a6750bb3bb1cd7be431e5636bae61237
Package Size:  822K
Installed Size:  4230K

Sources:  http://vectorlinux.osuosl.org/veclinux-6.0/source/testing/x-apps/abiword-plugins

Code:
abiword-plugins: (Abiword Plugins)
abiword-plugins:
abiword-plugins: Plugins to extend the functionality of the
abiword-plugins: AbiWord word processor.
abiword-plugins:
abiword-plugins:
abiword-plugins:
abiword-plugins:
abiword-plugins: License: GNU General Public License, version 2
abiword-plugins:
abiword-plugins:  Website: http://www.abisource.com


Package:  asio-1.2.0-i586-1vl60.tlz
MD5:  b9ff557b8c02e5bbc77eef4c01b3b7f5
Package Size:  128K
Installed Size:  1620K

Sources:  http://vectorlinux.osuosl.org/veclinux-6.0/source/testing/dev/asio

Code:
asio: asio (C++ library for network and low-level I/O programming)
asio:
asio: Asio is a cross-platform C++ library for network and low-level
asio: I/O programming that provides developers with a consistent
asio: asynchronous model using a modern C++ approach.
asio:
asio:
asio: License: Boost Software License, Version 1.0
asio: Authors: Christopher M. Kohlhoff (chris at kohlhoff dot com)
asio: Website: http://tenermerx.com/Asio/


Package:  libshoes-1.0.0-i586-1vl60.tlz
MD5:  50353408ce8553b41beade313673210f
Package Size:  32K
Installed Size:  120K

Sources:  http://vectorlinux.osuosl.org/veclinux-6.0/source/testing/libs/libshoes

Code:
libshoes: libshoes (SOCKS4 and SOCKS5 client library)
libshoes:
libshoes: libshoes is a portable C/C++ SOCKS4 and SOCKS5 client library
libshoes:
libshoes:
libshoes:
libshoes:
libshoes: License: not specified
libshoes: Authors: AbiSource Corporation B.V.
libshoes: Website: http://www.abisource.com

After testing these packages please let us know how they work for you.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #1 on: January 30, 2009, 10:51:24 am »

Installing them ATM, just a quick note meanwhile: maybe abiword-docs, abiword-extras and abiword-plugins should have abiword as a dependency? Let you know how they work in a bit.


EDIT: Too many tabs open...! I posted this in the link-grammar thread, instead of the abiword one. So I split it off and merged it. Sorry about that... Embarrassed
« Last Edit: January 30, 2009, 12:53:18 pm by Joe1962 » Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« Reply #2 on: January 30, 2009, 11:24:22 am »

I'd have to add that dependency manually in the script.  It does make sense though.  The problem is it takes a long time to build plugins on the hardware I have.  I can edit the slack-required on that one and add the code to the build script, though.  Let me get back to you on that  Grin
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
caitlyn
Moderator
Vectorian
*****
Posts: 2876


WWW
« Reply #3 on: January 31, 2009, 11:17:10 pm »

I've pulled all four original AbiWord packages and replaced them with ones tagged 2vl60.  The second build addresses the following issues:

  • built against goffice 0.6.6 instead of goffice 0.7.2.  0.7.2 caused problems for gnumeric
  • dependency for the main abiword package added to the other packages

Please test these new packages and let us know how they work for you.  The source links above are still correct.

Package:  abiword-2.6.6-i586-2vl60.tlz
MD5:  3575062bf7e87da936913fe5b20cc683

Package:  abiword-docs-2.6.6-i586-2vl60.tlz
MD5: e2cd666e8822e9de76557ba6db2fee16

Package:  abiword-extras-2.6.6-i586-2vl60.tlz
MD5:  910b62e2b41bcd31cca48bd5b2c9facf

Package:  abiword-plugins-2.6.6-i586-2vl60.tlz
MD5:  a745b012df3b74daf9a64974aebe348b
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #4 on: February 02, 2009, 07:38:40 am »

  • built against goffice 0.6.6 instead of goffice 0.7.2.  0.7.2 caused problems for gnumeric

Indeed, I did not test gnumeric after upgrading abiword and co. as well as goffice, A quick test shows it was missing libgoffice-0.6.so.6. However, a simple symlink got it working:
Code:
ln -s /usr/lib/libgoffice-0.8.so.7.0.2 /usr/lib/libgoffice-0.6.so.6
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!