VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: [Solved] Mousepad Saving Locale  (Read 1705 times)

Pita

  • Vectorian
  • ****
  • Posts: 1338
[Solved] Mousepad Saving Locale
« on: January 30, 2009, 06:08:20 pm »

I am just changing from my previous text editor to mousepad since it can display
certain characters correctly. Now if I try to save a file the 'save as' window shows
a bar "Current Locale (ISO-8859-1)". If I then try to save I get: "Can't convert codeset to 'ISO-8859-1'"
and the save window is gone.

In order to save I have to change this Current Locale to UTF-8 in the save window.

How can I make it permanent  UTF-8?

There is a mousepadrc, however, I would not know what to enter.

Thanks & regards
« Last Edit: January 31, 2009, 06:47:18 pm by Pita »
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: Mousepad Saving Locale
« Reply #1 on: January 30, 2009, 10:34:31 pm »

Change the variable LANG in /etc/profile.d/lang.sh from en_US to en_US.utf8.  That will enable utf8 across the board.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

Pita

  • Vectorian
  • ****
  • Posts: 1338
Re: Mousepad Saving Locale
« Reply #2 on: January 31, 2009, 06:46:33 pm »

Thanks! It works.

Regards
Logged