VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: xmame on VL-Light5.9  (Read 3284 times)

root

  • Member
  • *
  • Posts: 28
xmame on VL-Light5.9
« on: February 07, 2009, 07:41:06 am »

Hey guys , i'v just downloaded xmame-0.103.tar.bz2 and after extracting it in a folder , i don't really know from where to run the game , when i try ''xmame'' or ''xmame-0.103'' in console command is not found , any ideas from where can i start the game ? or this wont work for VL-Light_5.9 ?

Thanks .
Logged
minimal monster

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4085
Re: xmame on VL-Light5.9
« Reply #1 on: February 07, 2009, 01:49:56 pm »

Look in the folder for a README file. You probably need to compile the program.
Logged

root

  • Member
  • *
  • Posts: 28
Re: xmame on VL-Light5.9
« Reply #2 on: February 09, 2009, 11:07:47 am »

Thanks for the reply nightflier , i checked the README file and yes i have to compile it , but this will be bit of a problem since i don't really know how to do this , but tonight i got some time and i'll search for some info abour this .

Cheers , Junior .
Logged
minimal monster

root

  • Member
  • *
  • Posts: 28
Re: xmame on VL-Light5.9
« Reply #3 on: February 12, 2009, 12:58:16 pm »

Ok , so i've manage to install the game by ''make install'' , but can't start it now  ??? , can't find icon either ''xmame'' works in terminal , any ideas how can i run the game ?
Logged
minimal monster

OU812

  • Vectorite
  • ***
  • Posts: 156
Re: xmame on VL-Light5.9
« Reply #4 on: February 15, 2009, 06:56:45 am »

I haven't actually gotten mame to work, just too many other things going on. From what I understand, no matter what version you're using, it seems that you can't just set up a directory with your roms and launch the app. I'm fairly certain - at least to get things started - you need to have a rom image somewhere in the / directory. Then you should be able to configure it. (I get this impression from a successful I once did and when I ran it - forgot which version - it complained about not finding some particular roms.) Try the readme files again and see if you overlooked something.

john
Logged

root

  • Member
  • *
  • Posts: 28
Re: xmame on VL-Light5.9
« Reply #5 on: March 26, 2009, 08:48:01 am »

I haven't actually gotten mame to work, just too many other things going on. From what I understand, no matter what version you're using, it seems that you can't just set up a directory with your roms and launch the app. I'm fairly certain - at least to get things started - you need to have a rom image somewhere in the / directory. Then you should be able to configure it. (I get this impression from a successful I once did and when I ran it - forgot which version - it complained about not finding some particular roms.) Try the readme files again and see if you overlooked something.

john

Hey John , thanks for the tip . I actually didnt't have any time to deal with this , but i got this week off from work so i'll see what i can do about it  :)
Logged
minimal monster

MarkGrieveson

  • Vectorian
  • ****
  • Posts: 531
Re: xmame on VL-Light5.9
« Reply #6 on: March 12, 2012, 09:27:44 pm »

If I remember correctly, after installing xmame, if you have a rom file (which is a compressed game file for xmame or mame), put it in either the system rom directory (which I think is at /usr/share/xmame/rom) or put it in your home directory in the hidden file of xmame (/home/user/.xmame/rom).  The former can be played by any user on the system, while the latter can only be played by the specific user.  To run, enter the command "xmame game" (IE, "xmame robotron" if you have that rom).
Logged
I am using VL7.0 standard with XFCE