VectorLinux
October 24, 2014, 10:39:04 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Recommended Timeserver ?  (Read 2548 times)
johnpipe108
Member
*
Posts: 26


« on: February 07, 2009, 11:47:15 pm »

I'm running Vl-5.8, and it always initializes the system time from the hwclock, a bad idea because it's always wrong.  On my other system I installed xntpd, but IIRC there's no package for VL, so it would be a lot of work.  Is there some other timeserver,  package for VL, so I can have the system time set from my ISP timeserver?

Thanks in advance,

Johnpipe
Logged
fox
Member
*
Posts: 38



« Reply #1 on: February 08, 2009, 05:09:43 am »

Timeserver?  I didn't know that VL sets a clock by a timeserver.  How does one check this in VL?

I'm running it as a virtual machine on my Mac, but every time I freeze and restart the machine, the time is not being reset.  On other distros this doesn't happen, so I'm wondering if no timeserver was installed by default.
Logged

Mac user with Linux tendencies
Intel iMac 2.16ghz C2D; Mac mini 1.83ghz C2D
MSI Wind U100, 2ghz RAM, 80gb HD, Gigabyte atheros wireless
PowerBook G4/1.33 15" Al
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #2 on: February 08, 2009, 05:37:49 am »

On my 5.8 system I use "ntpdate" and a line in rc.local: "ntpdate -b pool.ntp.org"
The "ntp" package is in VL6 repo, not sure about 5.9 and earlier.
Logged
johnpipe108
Member
*
Posts: 26


« Reply #3 on: February 08, 2009, 10:44:03 am »

Thanks, ntpdate will work, it isn't installed on 5.8 an I did not know where to find it. I'll look for the ntp package in Gslapt.
Logged
johnpipe108
Member
*
Posts: 26


« Reply #4 on: February 08, 2009, 10:48:43 am »

Timeserver?  I didn't know that VL sets a clock by a timeserver.  How does one check this in VL?

I'm running it as a virtual machine on my Mac, but every time I freeze and restart the machine, the time is not being reset.  On other distros this doesn't happen, so I'm wondering if no timeserver was installed by default.

VL does not check a timeserver, that's the problem. AFAIK, no version of VL includes a timeserver (not sure if any distro includes one by default). If one is running a network, and wants to keep all the machines on the same time, xntpd server is a good call; IIRC, it has to be built on the system as there's no slackware packages.
Logged
bigpaws
Vectorian
****
Posts: 1856


« Reply #5 on: February 08, 2009, 10:55:16 am »

Slackware includes ntp by default

Bigpaws
Logged
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #6 on: February 08, 2009, 05:20:19 pm »

ntp is in the repo for both VL 5.9 and VL 6.0.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
fox
Member
*
Posts: 38



« Reply #7 on: February 09, 2009, 08:03:53 am »

I installed ntp, but I hasn't changed anything.  Horage clock in my virtual machine with VL still gives the incorrect time and date.  This is the only distro I've tried that does this, but it's the first one I've tried that is Slackware-based.  I noticed that neither VMware Fusion or VirtualBox specify Slackware options when you first set up the virtual machine.  Perhaps that's the problem?
Logged

Mac user with Linux tendencies
Intel iMac 2.16ghz C2D; Mac mini 1.83ghz C2D
MSI Wind U100, 2ghz RAM, 80gb HD, Gigabyte atheros wireless
PowerBook G4/1.33 15" Al
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #8 on: February 09, 2009, 10:25:51 am »

Installing ntp by itself will not set up your system to automatically get some server time. You need to use the method described by nightflier above.

The easier way to do it, and faster than ntp is to install "rdate" from www.linuxpackages.net and then put a command like this in your /etc/rc.d/rc.local file:

rdate -s time.nrc.ca && hwclock --systohc

But first of all just set the correct time using "vasm", maybe that is all you really need to do rather than setting up a time server thing.
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
fox
Member
*
Posts: 38



« Reply #9 on: February 12, 2009, 06:33:45 am »

Thanks for the suggestion, lagagnon.  As it turns out, my time problem righted itself with the latest version of VMware Fusion (2.0.2), which was just posted yesterday.  My VL virtual machine now keeps proper time, and the correct time is shown following the revival of a saved state.  Smiley
Logged

Mac user with Linux tendencies
Intel iMac 2.16ghz C2D; Mac mini 1.83ghz C2D
MSI Wind U100, 2ghz RAM, 80gb HD, Gigabyte atheros wireless
PowerBook G4/1.33 15" Al
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!