VectorLinux
September 02, 2014, 01:36:12 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Can't connect to huawei E220  (Read 857 times)
Robert S
Member
*
Posts: 7


« on: February 16, 2009, 03:29:11 am »

I used to have my huawei E220 G3 USB modem working nicely on VL-5.9 - on an ancient Gateway Solo 2150 notebook.  I recently upgraded to VL06.9-RC4.

Now when I connect my device, the /dev/ttyUSB{0,9} devices temporarily appear then disappear.  The logs suggest that the device is being repeatedly connected and disconnected:

Feb 16 22:17:39 Vector kernel: usb 3-2: new full speed USB device using ohci_hcd and address 2
Feb 16 22:17:39 Vector kernel: usb 3-2: configuration #1 chosen from 1 choice
Feb 16 22:17:39 Vector kernel: scsi2 : SCSI emulation for USB Mass Storage devices
Feb 16 22:17:39 Vector kernel: usb 3-2: USB disconnect, address 2
Feb 16 22:17:40 Vector kernel: usb 3-2: new full speed USB device using ohci_hcd and address 3
Feb 16 22:17:40 Vector kernel: usb 3-2: configuration #1 chosen from 1 choice
Feb 16 22:17:40 Vector kernel: scsi5 : SCSI emulation for USB Mass Storage devices
Feb 16 22:17:41 Vector kernel: usbcore: registered new interface driver usbserial
Feb 16 22:17:41 Vector kernel: usbserial: USB Serial support registered for generic
Feb 16 22:17:41 Vector kernel: usbcore: registered new interface driver usbserial_generic
Feb 16 22:17:41 Vector kernel: usbserial: USB Serial Driver core
Feb 16 22:17:41 Vector kernel: usbserial: USB Serial support registered for GSM modem (1-port)
Feb 16 22:17:41 Vector kernel: option 3-2:1.0: GSM modem (1-port) converter detected
Feb 16 22:17:41 Vector kernel: usb 3-2: GSM modem (1-port) converter now attached to ttyUSB0
Feb 16 22:17:41 Vector kernel: option 3-2:1.1: GSM modem (1-port) converter detected
Feb 16 22:17:41 Vector kernel: usb 3-2: GSM modem (1-port) converter now attached to ttyUSB1
Feb 16 22:17:41 Vector kernel: usbcore: registered new interface driver option
Feb 16 22:17:41 Vector kernel: option: USB Driver for GSM modems: v0.7.2
Feb 16 22:17:45 Vector kernel: usb 3-2: USB disconnect, address 3
Feb 16 22:17:45 Vector kernel: option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
Feb 16 22:17:45 Vector kernel: option 3-2:1.0: device disconnected
Feb 16 22:17:45 Vector kernel: option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
Feb 16 22:17:45 Vector kernel: option 3-2:1.1: device disconnected

..etc.

Does anybody have any suggestions?  I've tried the huaweiAktBbo and usb_modeswitch binaries recommended on various forums, and I've got the usbserial and option modules loaded - all with no success.  I'm wondering if the 2.6.27.12 kernel doesn't agree with my ancient hardware.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!