VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: How to configure an HP All-in-one on Vector Linux  (Read 3292 times)

NL_Derek

  • Member
  • *
  • Posts: 5
How to configure an HP All-in-one on Vector Linux
« on: February 21, 2009, 12:04:47 pm »

This is how I got my HP PSC1417 working on VL 5.9.1 SOHO. I think some of the tricks and techniques will help in similar configurations, but your mileage may vary.

I have tried to give some explanation and an indication of how to track down problems. If you find this didactic, sorry in advance. The main tools I use were find, man and good ol' google.

First we need software: CUPS (Common Unix Printing System) to handle the queues, HPLIP/HPIJS (HP Linux Imaging and Printing) to drive the printer, and SANE/XSANE (Scanner Access Now Easy) to interface with the scanner part. I used gslapt to install CUPS 1.3.7, HPLIP 2.8.5, HPIJS 2.1.4, SANE 1.0.19 and XSANE 0.994.

Now we need to mend a couple of things:

CUPS 404 problem; when you start CUPS via Vector Control Center>Utilities>CUPS you get 404 not found.
CUPS is distributed over two locations; on my system these are /usr/doc/cups-1.3.7 where index.html is located (with a symlink to /usr/doc/cups), and /usr/share/cups where various daemon data are located. On some systems these two cannot find each other. The solution is to edit (as root) /etc/cups/cupsd.conf and add the line

DocumentRoot /usr/doc/cups

HPLIPS and CUPS seem to disagree about locales -- the locale is what tells the system what language (English, French, Russian) to use. The locale also controls the character set, and if you look in /var/log/cups/error_log you may see "Unsupported character set".
This is a workaround and I hope that a guru can think of a systemic solution.
Edit (as root) /etc/profile.d/lang.sh and add the line

export LC_ALL=C

That should be enough for your printer, but unfortunately the LC_ALL change breaks vasmCC; clicking Utilities gives a "bad string conversion" The workaround is to go to /usr/share/vasmCC/utilities where the the icons are located. Look at them (more *) and you will find that some (in my case gslapt.desktop and hardinfo.desktop) contain unprintable characters, intended for the Bulgarians, Poles, Russians, Czechs, Ukrainians and similar among us. Much though I love those nationalities, I removed the unprintable lines (again, edit as root).

You need to have the CUPS daemon running;

VectorControlCenter>Service>Services, RunLevel 4, check cups and click OK.

Clever people know how to (re)start the daemon, but I just reboot.

You can install printers using KDE, using CUPS and using the HPLIP tools. I got the best results with HPLIP. Make sure your printer is switched on and connected.

As root run /usr/bin/hp-setup. Accept the defaults.

You also need to set the printer to be your default printer; start CUPS (VectorControlCenter>Service>CUPS) and it is pretty easy; Printers, Set As Default.

That's it. Your PSC should be able to print and scan. Now for a few extras....

On internet there is criticism of the quality of HPLIPS. I have to admit that the bug list of HP's Linux software is longer than the bug list of other printer manufacturers' Linux software... I wonder why?

You likely want to be able to see how much ink your printer has. HP provide a tool called hp-toolbox which has this facility. However this needs another daemon, hp-systray. I did not manage to get this working very well, but I went (as myself, not as root) to my home directory, then to ~/.kde/Autostart. I added a symbolic link (man ls) with:

ln -s /usr/bin/hp-systray hp-systray

and restart KDE. There in your SysTray is a pretty little blue HP icon; if you right-click it you can open the "HP Device Manager" (also accessible as /usr/bin/hp-toolbox) which provides several functions including the ink level. [As I test this HowTo, it doesn't work! No doubt if I restart it'll work, but I have to agree that HPLIPS is sometimes flaky. But it's better (IMHO) than the rest.]

Call to gurus: I think that hp-toolbox (including the ink level) belongs in vasmCC (as well as at user level). I was unable to get this working. I added hp-toolbox to vasmCC but never got it to work properly.

Extra: put the official CUPS icon into vasmCC. Edit (as root) /usr/share/vasmCC/service/vcupsweb.desktop. Change the Icon line to

Icon=/usr/doc/cups/favicon.ico

I wish you lots of success with Vector and HP.

--- Derek
Logged

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: How to configure an HP All-in-one on Vector Linux
« Reply #1 on: February 22, 2009, 06:31:44 pm »

With regard to "when you start CUPS via Vector Control Center>Utilities>CUPS you get 404 not found," it's been that way for a long time. You don't need to edit any files to get into CUPS. You can simply add admin after
http://localhost:631/

like this:
http://localhost:631/admin

That will get you into the CUPS screens for adding printers, modifying, printing test pages, checking jobs, etc. You could use /printers instead of /admin or any of the options available in CUPS, but it's easier to remember /admin than a variety of choices.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

NL_Derek

  • Member
  • *
  • Posts: 5
Re: How to configure an HP All-in-one on Vector Linux
« Reply #2 on: February 26, 2009, 10:57:10 am »

Yes, I had discovered http://localhost:631/admin but (at least on my system) I do not get all the nice icons. Editing cupsd.conf gives me CUPS with a friendlier-looking interface. I strongly recommend adding the extra line to cupsd.conf in the distro. But thanks for your reply.

--- Derek
Logged

sparkyhall

  • Vectorite
  • ***
  • Posts: 118
Re: How to configure an HP All-in-one on Vector Linux
« Reply #3 on: February 27, 2009, 05:04:25 am »

CUPS 404 problem; when you start CUPS via Vector Control Center>Utilities>CUPS you get 404 not found.
CUPS is distributed over two locations; on my system these are /usr/doc/cups-1.3.7 where index.html is located (with a symlink to /usr/doc/cups), and /usr/share/cups where various daemon data are located. On some systems these two cannot find each other. The solution is to edit (as root) /etc/cups/cupsd.conf and add the line

DocumentRoot /usr/doc/cups


Big thanks for this snippet of info, fixes my CUPS 404 error a treat.
Logged