VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Cannot change the keymap  (Read 1536 times)

ilvaiani

  • Member
  • *
  • Posts: 17
Cannot change the keymap
« on: February 21, 2009, 02:00:41 am »

Hello everybody. I have a problem with the keyboard configuration. We're talking about an HP (Compaq-something) laptop. Now, I'm from Italy and therefore I need an Italian keymap - just the one I've always used. So, as root and not in the Xwindow mode, I start the VASM, go into the hardware configuration and select the italian keymap, I check it and it works right, I select it and everything seems right. Now, I think, I can write as usual.
But then I start the Xwindow mode, open - say - Kword (or just a terminal) and the keys are not where I expect. So I open the VASM through a terminal and execute the same operation as before: I can't even check the italian keymap succesfully.
How do I fix the matter?

Thanks in advance!
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2879
    • The Linux Works
Re: Cannot change the keymap
« Reply #1 on: February 21, 2009, 09:57:24 am »

As root, open /etc/X11/xorg.conf in your favorite text editor.  Find a section that looks like this:

Code: [Select]
Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
Option  "XkbLayout"  "us"    ## KEYBOARD_MAP!
Option  "XkbModel"  ""    ## KEYBOARD_MODEL!
Option  "Xkbvariant"  ""    ## KEYBOARD_VARIANT!
EndSection

Change the fourth line to:

Code: [Select]
Option  "XkbLayout"  "it"    ## KEYBOARD_MAP!
The next time you start X it should be corrected.

That's it!
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

ilvaiani

  • Member
  • *
  • Posts: 17
Re: Cannot change the keymap
« Reply #2 on: February 21, 2009, 11:57:31 pm »

Trouble: I cannot open /etc/X11/xorg.conf, for the answer is: Permission Denied.
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1872
Re: Cannot change the keymap
« Reply #3 on: February 22, 2009, 04:45:13 am »

In order to edit that file you need to be root.

In a terminal (console) type su

Now enter the root password

now type mcedit /etc/X11/xorg.conf

That will open the file and let you edit it. Then use F2 to save the file and
then use F10 to exit midnight commander.

After that you will need to restart X in order for the changes to take effect.

Bigpaws
Logged

ilvaiani

  • Member
  • *
  • Posts: 17
Re: Cannot change the keymap
« Reply #4 on: February 23, 2009, 10:11:03 am »

It works! Thanks!
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2879
    • The Linux Works
Re: Cannot change the keymap
« Reply #5 on: February 23, 2009, 10:14:00 am »

Glad you got it working.  Please, when a problem is solved for you, take a moment to modify the Subject of your original post to include [SOLVED].

Thanks.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1