VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: libpng update question  (Read 1519 times)

lm8

  • Packager
  • Member
  • ****
  • Posts: 83
libpng update question
« on: February 26, 2009, 05:11:47 am »

What's the best way to install the libpng update (1.2.35) if you're on sneakernet (no direct Internet connection to the machine)?  Can someone post some basic steps to follow?

Thanks.
Logged

kc1di

  • Packager
  • Vectorian
  • ****
  • Posts: 1125
  • Morse Code Early digital mode. John 3:16
Re: libpng update question
« Reply #1 on: February 26, 2009, 07:22:35 am »

What's the best way to install the libpng update (1.2.35) if you're on sneakernet (no direct Internet connection to the machine)?  Can someone post some basic steps to follow?

Thanks.


Hi IM8

I think you should be able (if you have a machine connected to the internet) download the .tlz from http://ftp.osuosl.org/pub/vectorlinux/veclinux-6.0/testing/libs/
burn it to disc or flash memory and install it with installpkg on the machine in question.  Of course if you run into dependency problems you'll have to find each file that's needed.

Dave
Logged
Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3487
Re: libpng update question
« Reply #2 on: February 26, 2009, 07:26:44 am »

BTW, while we are at it... can we get someone to update our libpng package? I think the slack version is broken or is missing some link

I just tried to build something that requires it (after having installed the slack version of the package) and my package failed to build...
so I downgraded to the old VL version, and my package built just fine.

kc1di

  • Packager
  • Vectorian
  • ****
  • Posts: 1125
  • Morse Code Early digital mode. John 3:16
Re: libpng update question
« Reply #3 on: February 26, 2009, 07:55:26 am »

BTW, while we are at it... can we get someone to update our libpng package? I think the slack version is broken or is missing some link

I just tried to build something that requires it (after having installed the slack version of the package) and my package failed to build...
so I downgraded to the old VL version, and my package built just fine.

I Think rbistolfi has already done that it should be in testing.
dave

Logged
Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2920
    • The Linux Works
Re: libpng update question
« Reply #4 on: February 26, 2009, 11:47:20 am »

No, he hasn't.  He converted the Slackware package and I agree that it's broken.  I've pinged him on it.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VL64 7.1

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

kc1di

  • Packager
  • Vectorian
  • ****
  • Posts: 1125
  • Morse Code Early digital mode. John 3:16
Re: libpng update question
« Reply #5 on: February 26, 2009, 03:11:04 pm »

No, he hasn't.  He converted the Slackware package and I agree that it's broken.  I've pinged him on it.

Thanks Caitlyn,
That explains why the package I've been trying to build will not build.  it needs libpng. And I had hopes that the one he packaged would work but it does not.

Dave
 :(
Logged
Dave
( Living Somewhere in Maine USA)
Registered Linux User #462608