VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: KVM's and grub/lilo multiboots w/VL  (Read 1364 times)

Windozer

  • Vectorite
  • ***
  • Posts: 386
  • Have Vector Linux, Will Travel.
KVM's and grub/lilo multiboots w/VL
« on: February 09, 2009, 09:35:12 am »

OK, this one's a bit arcane...

I've got two machines running off one KVM. The KVM is a newer one that uses a USB mouse and keyboard but does not have a separate cable for each computers' mouse and keyboard. (They are sent in via ONE usb port.)

When it boots to grub, the keyboard doesn't work yet - So I'm unable to select which OS to use.  Interestingly, at initial boot the BIOS does recognize it - (I can go into system setup before getting to grub.)   Once the defaulted-to OS runs (some flavor of VL 6) everything works fine.  (I could just plug a regular keyboard into each machine at boot, but that sort of defeats the KVM idea in the first place.)

Am I correct that this means that GRUB itself does not have drivers to recognize a USB keyboard?

I haven't tried using LILO for this config - would it work instead?

thanks for the assist.
- Howard
Logged
483,617th Registered Linux Snoozer

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2876
    • The Linux Works
Re: KVM's and grub/lilo multiboots w/VL
« Reply #1 on: February 26, 2009, 04:05:07 pm »

GRUB can and does recognize USB keyboards.  I've had problems with KVMs with both lilo and grub and with operating systems other than Linux.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1