Author Topic: Disable eth0  (Read 4690 times)

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3287
  • -- Just being myself --
Disable eth0
« on: March 26, 2009, 09:17:20 pm »
I am currently using laptop for VL6/5.9 and most of the time I use my wireless card to connect to network. Is there a way to disable the wire NIC in VL?

sledgehammer

  • Vectorian
  • ****
  • Posts: 1527
Re: Disable eth0
« Reply #1 on: March 27, 2009, 12:14:58 am »
You got me, hata_ph.  Its easy to turn the wired icon on and off in WICD, but I don't know what "wire NIC" is, nor why one would want to turn it off.   Sorry.

But THANKS for putting lyx 1.6.1 in the repositories for VL 6.0

John
« Last Edit: March 27, 2009, 12:12:09 pm by sledgehammer »
VL7.0 xfce4 Samsung RF511

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3287
  • -- Just being myself --
Re: Disable eth0
« Reply #2 on: March 27, 2009, 01:48:49 am »
NIC = Network Interface Card :)

BTW, I have packaged lyx-1.6.2 for VL6 and 5.9. Maybe you can have a try once it is uploaded to the testing repo. :P

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4508
Re: Disable eth0
« Reply #3 on: March 27, 2009, 05:56:35 am »
vasm > network > inet > del

bigpaws

  • Administrator
  • Vectorian
  • *****
  • Posts: 1909
Re: Disable eth0
« Reply #4 on: March 27, 2009, 05:59:00 am »
rmmod the kernel module for the NIC and then blacklist it
in /etc/modprobe.d/blacklist.

When you want or need the NIC you can then just modprobe the
module, ifconfig eth0 up and the dhcpcd eth0.

Bigpaws

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3506
Re: Disable eth0
« Reply #5 on: March 27, 2009, 06:12:19 am »
ifconfig eth0 down

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3287
  • -- Just being myself --
Re: Disable eth0
« Reply #6 on: March 27, 2009, 07:57:57 am »
ifconfig eth0 down

can i put it in rc.local to disable it at start up?

Will disable unwanted hardware like this free up system resource?

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3506
Re: Disable eth0
« Reply #7 on: March 27, 2009, 08:10:07 am »
If you dont want it to come up at all, the blacklist method is a lot better
Get the module name from /etc/modules.conf
Code: [Select]
cat /etc/modules.conf | grep eth0add the module to the blacklist
Code: [Select]
echo "blacklist <name_of_module>" >> /etc/modprobe.d/blacklist