VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: What's that ? KDE hacked VL's login screen !  (Read 2108 times)

demigaucher

  • Member
  • *
  • Posts: 58
What's that ? KDE hacked VL's login screen !
« on: February 28, 2009, 06:40:45 am »

Hi everybody

First, congratulations and thanks to all the VL team for VL6.0:
beautiful artwork, nice graphical installer, better internationalization.
Great task !  VL is clearly on the way up to the top of distrowatch
page.

I want to report the following (minor) problem: the login screen of
VL6.0 (in which I type my login name and passord) has been replaced
by another one, clearly from KDE (the graphics with the gearbox leaves
no doubt). This occured after having installed, with gslap, some kde
packages.

To pin down the problem, I made a pristine install of VL6.0, then installed
with gslapt the package "kdebase", and logged out. At reboot, a KDE login
screen had superseded the original one from VL !

This does not prevent the login, but is irritating since I did not ask KDE to hack
my login screen ! I want to use some packages from KDE, like ksnapshot, kedit,
etc... and I think  kdebase is needed, but I would like to re-establish the original
VL's login screen.

Has someone an idea ?


Demigaucher
Old Pentium 3 @ 700 MHz, 384 MB ram

Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2880
    • The Linux Works
Re: What's that ? KDE hacked VL's login screen !
« Reply #1 on: February 28, 2009, 07:10:36 am »

With vasmCC or vasm click XWindow, click Display Manager, select gdm.

That should do it.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3279
Re: What's that ? KDE hacked VL's login screen !
« Reply #2 on: February 28, 2009, 07:11:13 am »

the kdebase package does that. You can fix it by editing /etc/rc.d/rc.X and change the line that says KDM to GDM

demigaucher

  • Member
  • *
  • Posts: 58
Re: What's that ? KDE hacked VL's login screen !
« Reply #3 on: February 28, 2009, 12:46:42 pm »

Hi Caitlyn, Hi MOE-Inx.

I'll try now your solutions. Thanks to both of you for your answers.

Demigaucher
Old Pentium 3 @ 700 MHz, 384 MB ram

Logged

demigaucher

  • Member
  • *
  • Posts: 58
Re: What's that ? KDE hacked VL's login screen !
« Reply #4 on: March 02, 2009, 05:38:09 am »

Hi Caitlyn, Hi MOE-Inx

I tried both of your suggestions:

1) Caitlyn's suggestion: after selecting GDM in VASM, I was asked to logout, and enter a command-line console
    with CTL-ALT-F1. Unfortunately, CTL-ALT-F1 did NOT give a command-line terminal, but a fixed blue screen
    with the nice VL logo in the center  :(  [CTL-ALT-F7 gave me back my graphical screen  :) ]. So I could not
    proceed further, and tried the next action:
2) MOE-Inx's suggestion: I modified /etc/rc.d/rc.X  + reboot. Worked fine, ant the nice VL's login screen is back :)

Problem solved, thanks to both of you. But did somebody else observe this strange behaviour of CLT-ALT-F1 ?
(We can live with it, anyway !)

Best regards to all.

Demigaucher
Old Pentium 3 @ 700 MHz, 384 MB ram
Logged