VectorLinux
April 23, 2014, 04:35:19 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Howto: Easy Linux-to-Windows file sharing using thunar  (Read 5529 times)
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« on: March 02, 2009, 07:01:27 am »

Preface
This howto explains how to setup files / directories in a VectorLinux 6.0 machines for sharing on a local network. This howto assumes you are running the stock VectorLinux 6.0 with the xfce4 desktop environment, and thunar as the file manager.

This howto assumes you have already setup your samba server user accounts on the VectorLinux box.

Let's get started.

Install Necessary Software

Click on Menu -> System -> Gslapt
Gslapt will ask you for your root password, so feed it your root password
Once Gslapt is opened, click on Edit -> Preferences -> Sources
Once there, make sure the "testing" repository is enabled. See http://upload.snelhest.org/images/090302Screenshot-4.png for example.
Click "OK" and then click the "Update" icon on the Gslapt main window. This will refresh your available software catalog.
In the search bar, type "thunar-shares-plugin"
Select the result that matches the search, click on the box under "status" and select "Install"
Click "Execute"
At this point you'll be presented with a confirmation window, click OK and it will install the required packages.

Before you can share
After the package is installed, you will need to log out of your current session, and log back in for your changes to take effect. The package should have warned your about that.

You also need to make sure your samba service is ran at startup for seamless operation, so here is how to do that.
Click on Menu -> System -> Vector Control Center
Again, feed it your root password.
Click "SERVICE" on the left panel
Click the "Services" icon on the right panel
Click on "4 Graphical User Interface Desktop"
Scroll down and you should see an entry for "Samba: Samba daemon"
Make sure the checkbox is ticked (enabled)
Click OK, and exit your way out back to the control center and close it out too.

Setting up shares

So you're ready to setup your shared files.
Click the "home" icon on your Desktop
Select any file or directory in that folder (you must be the owner of the file or directory before you can share it)
Right-click the file/dir -> Properties
Click the "Share" tab
Tick the "Share this file/folder" checkbox and any other sharing options below it.
See here http://upload.snelhest.org/images/090302Screenshot-5.png

You are done.

Testing your shares

If you have a windows box running in the same network, you should be able to see your shared files now as usual from the windows box
You can test in a terminal by issuing the command
Code:
smbclient -L localhost
and the terminal should ask you for a password (this is your samba user password... if you have not setup one just hit enter). Then the terminal will respond with something like this
Quote
Domain=[MYGROUP] OS=[Unix] Server=[Samba 3.0.33]

   Sharename       Type      Comment
   ---------       ----      -------
   IPC$            IPC       IPC Service (Samba Server)
   screenies       Disk     
Domain=[MYGROUP] OS=[Unix] Server=[Samba 3.0.33]

   Server               Comment
   ---------            -------
   LOGOS                Samba Server

   Workgroup            Master
   ---------            -------
   MYGROUP              LOGOS

Troubleshooting

  • I dont see my shared data
*  Make sure the samba service is running on the linux box
*  Make sure you are the owner of the files or directories you are trying to share (files or directories created by root in your home folder are not owned by you... they're owned by root
*  Make sure all of your boxes in the network are in the same workgroup (see /etc/samba/smb.conf and look for the line that says "Workgroup")

  • I followed this howto and my "share" tab is still not showing up
*  Try restarting your computer


If you have any questions, please ask in the appropriate section of the forum. DO NOT POST QUESTIONS IN THE HOWTO SECTION. I cannot stress that enough.
Enjoy Wink
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!