Author Topic: [SOLVED] install VL to a SDHC  (Read 2916 times)


  • Member
  • *
  • Posts: 2
[SOLVED] install VL to a SDHC
« on: March 05, 2009, 06:00:31 am »
Hi all,

I'm very new to VL, but have some linux experience under my belt. I wanted to give VL a whirl on my eeepc and install it on a SDHC (I have several linux distros installed that way). The eeepc has two internal SSDs, which are usually sda and sdb; the SDHC is usually mounted as sdc; I have formatted it as 400MB swap; the rest (7GB) as ext3 for /. The installation process recognizes the card and installs to it; installation is smooth, and after restarting, lilo loads fine. However, it fails at mounting the root volume and craps out at this stage. The last lines of the boot message are:
Code: [Select]
VFS: Cannot open root device "822" or unknown-block(8,34)
Please append a correct "root"= boot option; here are the available partitions:
0800 3940272 sda driver: sd
  0801   3212968 sda1
  0802     706860 sda2
  0803         8032 sda3
  0804         8032 sda4
0810   15761088 sdb driver: sd
  0811   15759733 sdb1
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,34)
So what seems to be happening: the boot process doesn't appear to "see" sdc at all. Maybe it's missing the drivers? Other linux distros include the usb_storage module in the initramfs or initrd.img, and I assume that's what is needed here (though, when I look at the kernel config, I see CONFIG_USB_STORAGE=y, which should mean that it's compiled into the kernel, right?). The lilo.conf written by the installer does not refer to the initrd:
Code: [Select]
# LILO configuration file
# generated by 'liloconfig'
# Start LILO global section
boot = /dev/sdc
default = linux
timeout = 100
# Override dangerous defaults that rewrite the partition table:
bitmap = /boot/bitmap/boot.bmp
# Normal VGA console
vga = normal
[some commented lines snipped]
# Partition 1: Linux GUI mode
image = /boot/vmlinuz
    root = /dev/sdc2
    label = linux
    append = " elevator=deadline"

But even adding the line "initrd = /boot/initrd" doesn't change anything. There's a symbolic link in the /boot directory README.initrd which points to /usr/doc/mkinitrd-1.1.2/README.initrd, which is not present on my system (the entire mkinitrd package seems to be missing). The funny thing is: lilo begins to boot from the card, so the system can obviously use it. What does it take to mount the root filesystem on this card? Can anybody help?

« Last Edit: March 05, 2009, 01:26:23 pm by pindar »


  • Member
  • *
  • Posts: 2
Re: install VL to a SDHC
« Reply #1 on: March 05, 2009, 01:25:53 pm »
OK, in the meantime I have found a bit more information: it seems that all the necessary drivers are compiled into the kernel. The problem is that the kernel boots too fast for the SDHC to settle and appear - so the remedy was pretty simple: I had to add the line "rootdelay=10" to my kernel line in grub's menu.lst (lilo didn't do anything for me). I'm now running VL, and it looks gorgeous!



  • Packager
  • Vectorian
  • ****
  • Posts: 682
Re: [SOLVED] install VL to a SDHC
« Reply #2 on: March 05, 2009, 01:52:30 pm »
Glad you solved, and now you can be a happy vectorite ;)

Btw, I think we have another slogan: "Vector Linux, too fast for your hardware"