VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: 1 [2]

Author Topic: Opera 9.64 loses Flash  (Read 11182 times)

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2301
Re: Opera 9.64 loses Flash
« Reply #15 on: March 15, 2009, 01:46:41 pm »

Nice catch!
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: Opera 9.64 loses Flash
« Reply #16 on: March 15, 2009, 09:23:42 pm »

Thanks for this suggestion. Unfortunately, it didn't get Flash working with my Opera 9.64. Flash has worked with SeaMonkey and Firefox all along. It's just Opera where it doesn't work.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

kukibl

  • Guest
Re: Opera 9.64 loses Flash
« Reply #17 on: March 16, 2009, 03:17:42 am »

Yes, the strange thing is that flash was working just fine in FF although nss wasn't installed. After I installed nss package, I got flash in Opera 9.64.

I've installed latest flash version (just copied libflashplayer.so to /usr/lib/mozilla/plugins directory) and upgraded stock Opera 9.63 with 9.64.

How did you installed 9.64? I've used VL's Opera SlackBuild script, slightly modified (version number and archive extension). Then upgraded 9.63 with upgradepkg command.
Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2301
Re: Opera 9.64 loses Flash
« Reply #18 on: March 16, 2009, 07:04:21 am »

AFAIK firefox ships its own libs, check /usr/lib/firefox-3.0.7/libnss3.so
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: Opera 9.64 loses Flash
« Reply #19 on: March 27, 2009, 10:42:25 am »

I've done more investigating and have interesting results. I installed Opera 9.64 on my Athlong 64 computer; Flash had already been updated to the latest version. This time I used the Slackware 11-and-later version offered at opera.com instead of my usual static tar.gz version. Flash continued to work with the latest Opera on that computer. I use the proprietary ATI driver on it.

Starting Opera from a terminal prompt on my other computers, I get error messages if I have plugins activated. The error messages aren't the same. I'm at the 1.3 GHz Celeron as I write this, and this is the error message:
Not GTK2 toolkit (got 0).

Opera itself works fine, but Flash does not. When I originally installed VL6 Standard Deluxe Opera 9.63 and Flash were working, but somewhere along the upgrade line Flash stopped working. This computer uses the xorg radeon driver. Flash works fine on SeaMonkey and Firefox.

My Turion 64 also has Flash non-working with Opera. The error message is different. I'll post it tonight when I'm using that computer. That computer uses the proprietary NVidia driver.

Can anyone explain what "Not GTK2 toolkit (got 0)" means and what I can do about it? All three computers have just about the same software, so how GTK2 toolkit disappeared is a mystery to me.

I should also mention that I removed Opera entirely from the Celeron computer and reinstalled with the same Opera-provided Slackware version as I used on the computer where Flash and Opera are working together. Same results--Flash doesn't work on the Celeron. I also reinstalled the latest Flash, which didn't help, either. I don't know what else to try.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Opera 9.64 loses Flash
« Reply #20 on: November 03, 2009, 08:56:12 pm »

Sorry for reviving such an old thread but I have seemingly fixed my issues with Opera 10.x and Flash 10.x working together.  The solution I used comes from here: http://www.murga-linux.com/puppy/viewtopic.php?t=48514

It's simply copying 7 seamonkey lib files from one location to another, as root:
cp /usr/lib/seamonkey/libnss3.so /usr/lib/
cp /usr/lib/seamonkey/libsmime3.so /usr/lib/
cp /usr/lib/seamonkey/libssl3.so /usr/lib/
cp /usr/lib/seamonkey/libplds4.so /usr/lib/
cp /usr/lib/seamonkey/libplc4.so /usr/lib/
cp /usr/lib/seamonkey/libnspr4.so /usr/lib/
cp /usr/lib/seamonkey/libnssutil3.so /usr/lib/


Restart opera
Hope this helps
Logged
Pages: 1 [2]