VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: VL6 - No automatic DHCP connection in startup  (Read 4625 times)

svgt

  • Member
  • *
  • Posts: 18
VL6 - No automatic DHCP connection in startup
« on: March 07, 2009, 06:32:56 am »

Hi,
After each startup I must enable my internet connection manually.

I do this with VSAM-CC > Network > Netconf > set network hostname > set network method DHCP.

Is there a chance to manage it in an automatic way?

Regards
Svgt
Logged

sledgehammer

  • Vectorian
  • ****
  • Posts: 1470
Re: VL6 - No automatic DHCP connection in startup
« Reply #1 on: March 07, 2009, 10:39:53 am »

I can't tell too much from your post.  However, I assume you are using VL 5.9 standard and trying a wireless connection.  If so, you might consider switching to VL 6.0.  Its wicd is supposed to do what you want and, I am told, it works reliably on some machines. Not (yet) on my T42, though. 

I am new to VL 6.0 myself (about a week into it), but can say that I now spend much more time getting online with my wireless than I did when using wifi-radar in VL 5.9.  I am not sure yet whether its me, WICD my ISP, or my computer, but my wireless often seems significantly slower.

John
Logged
VL7.0 xfce4 Samsung RF511

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: VL6 - No automatic DHCP connection in startup
« Reply #2 on: March 07, 2009, 12:21:45 pm »

Svgt:  Which version of Vector Linux are you running?  Let us know and we'll pass along instructions that work for your version. 

John:  What kind of a wireless chipset does your Thinkpad have?  It should be no problem to automate everything for you.

FWIW, wifi-radar is still available for VL 6.0, BTW.  It's in the repository.

I actually have had the opposite experience from yours. wicd has been flawless for me and everything is automatic.  I'm sure your issue is just a matter of configuration.

Regards,
Cait
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

svgt

  • Member
  • *
  • Posts: 18
Re: VL6 - No automatic DHCP connection in startup
« Reply #3 on: March 07, 2009, 03:05:13 pm »

I have just installed the newest  version:  VL6.0-std-gold. And I use no wireless things.

regards,
Svgt
Logged

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2314
Re: VL6 - No automatic DHCP connection in startup
« Reply #4 on: March 07, 2009, 06:28:18 pm »

Try disabling the wicd service from vasm > super > service > srvset > (your runlevel here) > wicd

If that doesn't do it, you could always add the commands needed to get you going at the end of your /etc/rc.d/rc.local file.
That would be something like:

Code: [Select]
ifconfig eth0 up
dhcpcd eth0 &

HTH
« Last Edit: March 07, 2009, 06:30:32 pm by rbistolfi »
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: VL6 - No automatic DHCP connection in startup
« Reply #5 on: March 07, 2009, 08:33:46 pm »

rbistolfi's approach may very well work.  I was actually going to suggest the opposite which has worked for some people in the forum.

Click on the network icon on your panel to open wicd-client.  You'll see an entry labeled "Wired Network".  Click on the little arrow to the left of the word Wired to open the network settings.  There is a box marked "use as default profile".  If it's checked then uncheck it.  If it's unchecked then check it.  Which setting works best seems to be hardware/driver dependent.  Try the one you aren't using now.  That has actually fixed the problem for some people.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

sledgehammer

  • Vectorian
  • ****
  • Posts: 1470
Re: VL6 - No automatic DHCP connection in startup
« Reply #6 on: March 07, 2009, 11:20:05 pm »

My wireless has been working well for several hours now.  It connected three times through wicd after three reboots, the last being some 6 hours ago, with no problem, so I am happy.

My chipset is the Atheros AR5212/AR5213.  I think (hope) my problem was my router, which to date has been very good.  I figured that out when I was able, in wifi-radar, to get on my neighbor's unencrypted wireless.  (I use wep) So I unplugged the router, waited 5 minutes, plugged it back in, and everything, including wicd, seems to work properly.  . 

As to Svgt's original post, when I am on a wired connection, wicd has ALWAYS automatically connected on reboot. 

I will not post again about wicd for at least a couple of weeks.  By then, I should be pretty familiar with it and less likely to unintentionally muddy the waters.

John
« Last Edit: March 08, 2009, 09:06:21 am by sledgehammer »
Logged
VL7.0 xfce4 Samsung RF511

svgt

  • Member
  • *
  • Posts: 18
Re: VL6 - No automatic DHCP connection in startup
« Reply #7 on: March 08, 2009, 11:36:06 am »

Hi Caitlyn,

your proposal works. The box was checked. I unchecked it. Thank you.

Regards
Svgt
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: VL6 - No automatic DHCP connection in startup
« Reply #8 on: March 08, 2009, 05:37:34 pm »

My chipset is the Atheros AR5212/AR5213. 

That's what I have in my Toshiba laptop, an AR5212.  It works perfectly using wicd for me.

Quote
I will not post again about wicd for at least a couple of weeks.  By then, I should be pretty familiar with it and less likely to unintentionally muddy the waters.

Well... if you have questions, concerns, or answers you should post.  Trying to help is a good thing and asking for help is never frowned upon in this forum.

Regards,
Cait
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2314
Re: VL6 - No automatic DHCP connection in startup
« Reply #9 on: March 08, 2009, 05:42:11 pm »

Nice work Cait and svgt, glad you got it working.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

sledgehammer

  • Vectorian
  • ****
  • Posts: 1470
Re: VL6 - No automatic DHCP connection in startup
« Reply #10 on: March 09, 2009, 07:25:10 am »

Thanks Caitlyn,

Wicd is working just fine now on my T42.  The "slowness" may have been a result of moving to 6.0, for after doing so I downloaded a lot of stuff, both from the VL6.0 repositories and elsewhere.  While downloading, use of the internet slows down.  Ergo my thought to wait for a couple of weeks.  I should have all my programs up and running by then. 

John
Logged
VL7.0 xfce4 Samsung RF511

svgt

  • Member
  • *
  • Posts: 18
Re: VL6 - No automatic DHCP connection in startup
« Reply #11 on: March 11, 2009, 03:46:47 am »

Hi Caitlyn,

in a second installation the behaviour of the system is different. There is also no connection to the web with wired network.  If I click the little arrow, then  I get only  the two choices:

hidden network
create ad-hoc network.

The wired connection should be made with a PCMCIA-adapter in a laptop.

Regards,
Svgt
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: VL6 - No automatic DHCP connection in startup
« Reply #12 on: March 11, 2009, 05:00:55 pm »

svgt:  You are describing a very different problem.  Here wicd sees your wireless connection but doesn't know your wired NIC exists at all.  I expect the problem isn't wicd.  Please post the output of the following:

/sbin/ifconfig -a
lsmod

Let's see if the kernel even recognizes your NIC first, and, if so, if an inet is being assigned.
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

svgt

  • Member
  • *
  • Posts: 18
Re: VL6 - No automatic DHCP connection in startup
« Reply #13 on: March 11, 2009, 07:03:23 pm »

Hi,

there had been a mistake in my description: there was  no arrow with the text wired connection. But only an arrow in the line before.

I just wanted to repeat the situation without internet connection, for documentation.

But all was running well. And I haven't changed any boxes.

Regards,
Svgt
Logged

Pita

  • Vectorian
  • ****
  • Posts: 1338
Re: VL6 - No automatic DHCP connection in startup
« Reply #14 on: March 12, 2009, 12:34:26 am »

I just installed VL-6-STD on a HP Mini-Note PC 2133. After first boot I had no Internet
connection. Clicking on WICD Network Manager did nothing, neither my usual
'rc.inet1 start' in such cases or ifconfig eth0 up.

I then did on the command line 'wicd start', then clicked again WICD Net. Mang.,
the wicd gui came up and I connected. On subsequent boots connection was automatic
and there is now the wicd applet on the panel.
Logged