VectorLinux
April 24, 2014, 02:49:24 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: JOE, Joe's Own Editor  (Read 1256 times)
d_s
Member
*
Posts: 16


« on: March 08, 2009, 11:40:43 am »

Hi all,

is someone taking care of the "joe" editor? It got updated to version 3.7 at 2008-11-03. And I just got version 3.5 installed via gslapt.

Best regards
Dirk
« Last Edit: March 08, 2009, 11:44:42 am by d_s » Logged
kidd
Packager
Vectorian
****
Posts: 682


« Reply #1 on: March 08, 2009, 11:53:35 am »

I was just packaging latest vim and emacs versions.  Now that I'm at editors I'm going to package latest joe right now.  It will be in the repos in few hours/days.  Please, come back to tell if it works or not for you.  If you know of any special flag I should put in configure, don't hesitate to post back!

Cya
Logged

d_s
Member
*
Posts: 16


« Reply #2 on: March 08, 2009, 12:56:28 pm »

Hi,

I didn't expect an answer that fast - wow. Sure, a few days are fine Smiley 'joe' isn't difficult to build, I did id form the sources several times (alas, not yet under VL) and as the website states, the dependencies are easy. Now I'm relieved, I feared I had to try myself and these days I hardly find time to use the PC except on sundays.

Edit:
If you know of any special flag I should put in configure, don't hesitate to post back!
Nothing special needed. At least I cannot remember anything. Except... You can choose whether to use "termcap" or "terminfo" capabilities. I always went with the default, but maybe VL introduces a preference?

Thank you very much!
Dirk
« Last Edit: March 08, 2009, 01:01:57 pm by d_s » Logged
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #3 on: March 08, 2009, 03:37:43 pm »

I'm doing repository maintenance now.  This package should show up in the testing repository sometime later tonight.  If you temporarily enable testing in gslapt you'll be able to install it in the normal way.

HTH,
Cait
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
d_s
Member
*
Posts: 16


« Reply #4 on: March 09, 2009, 12:36:46 am »

Worked seamlessly, like a charm Smiley

Quote
** Joe's Own Editor v3.7 ** (iso-8859-1) ** Copyright (C) 2008 **
Also installed the new "*diff" syntax highlighting (written by me, btw).

Btw. this means that VL is (most likely) the most sophisticated distro in respect to "joe", since the others I know are still on version 3.5  Grin

Thank you very much. Yay!
Dirk

P.S. (edit) :
Is this package exclusively VL-only or will the change go upstream to slackware once in a while? If not, should I inform the slackware people, too, or will you tell them to update that package?

Thanks again
Dirk
« Last Edit: March 09, 2009, 12:44:16 am by d_s » Logged
caitlyn
Packager
Vectorian
****
Posts: 2839



WWW
« Reply #5 on: March 09, 2009, 05:47:10 am »

Our packages are VL only and they are NOT compatible with Slackware.  Slackware doesn't support lzma compression, requires support of i486 technology (our minimum is 586) and is built to different standards. 
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
VLocity Linux 7.0-rc1

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video
VL 7.0 Light
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!