VectorLinux
October 25, 2014, 06:07:04 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: rw access disappearing?  (Read 1094 times)
amigaman
Member
*
Posts: 6


« on: March 08, 2009, 02:49:59 pm »

I noticed something bizarre after a reboot this afternoon... the write access I had to my external drives had disappeared.  Now the only thing I can do to write to those drives (which my data are on) is to log in as root. 

Here's the pertinent info from my /etc/fstab file, and I should note that although I only use VL6.0, the other 3 drives are formatted as FAT32.  I can always change this if need be.  I'm curious though as to why I can no longer write as myself, only as root.

#The Linux partitions

/dev/hda1     /home     reiserfs     noatime      0 2
/dev/hda3          /     reiserfs     defaults 0 1


# Shared Windows/Linux partition#/dev/hda1   /mnt/dos  msdos  umask=0   0  0
#/dev/hda1   /mnt/win  vfat   fmask=111,dmask=0,quiet,shortname=mixed,user  0  0
#/dev/hda1   /mnt/win  ntfs   umask=0   0  0
/dev/hdb1    /mnt/galactica  auto defaults,users 0 0
/dev/hde1    /mnt/pegasus auto defaults,users 0 0
/dev/hdf1    /mnt/atlantia auto defaults,,users 0 0
# Floppy disks
# The 'noauto' option indicates that the file system should not be mounted
# with 'mount -a' 'user' indicates that normal users are allowed to mount
# the file system.


Any ideas would be most helpful.  galactica is my data drive and my main apps (firefox, thunderbird,office, file manager) are tied to directories on this drive.  It's nothing to copy the data over but I'd rather not do that if I don't have to.

Thanks in advance!
Logged
wcs
Packager
Vectorian
****
Posts: 1144


« Reply #1 on: March 08, 2009, 04:27:50 pm »

I guess those fat partitions need to have the dmask=0 option set in /etc/fstab.
Have you tried mounting the drives with those permissions you see in the "vfat" commented line (fmask, dmask, etc.)?

I never know the difference between dmask/umask/fmask, but if it's something to do with that, it should all be in "man mount".
Logged
StrayBit
Vectorite
***
Posts: 373



« Reply #2 on: March 08, 2009, 04:50:43 pm »

I have two vfat partitions on one of my machines:
Code:
/dev/hda1   /mnt/WinDos  vfat   users,fmask=111,dmask=0,quiet,shortname=mixed,user  0  0
/dev/hdc1 /mnt/Win-arc vfat auto,noatime,users,suid,dev,exec,quiet,umask=0,check=s,shortname=mixed 0 0 #
I have had no problem reading or writing to them from the local machine, or from the Win98 machine via a Samba share.

When I boot to Windows, hda1 is C: and hdc1 is D:.

hth
Logged

Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!