VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Pages: [1] 2

Author Topic: Blank Volume Control[Solved]  (Read 5607 times)

StrayBit

  • Vectorite
  • ***
  • Posts: 420
Blank Volume Control[Solved]
« on: March 08, 2009, 06:27:49 pm »

Installed VL6.0 on a Compaq PIII 500MHz 256MB ram.  Initially, I was able to watch and listen to videos.  Since I installed thunar-shares, there has been no sound.  When I click the speaker, it just gives an empty dialog window.  Saw an entry in Distro Development/VL6-Std-GOLD-Bugs about "In XFCE if you right click on the speaker -> properties you can then select what the volume control adjusts from the wannabe Master menu. Or at least I can."

The wannabe box is empty and the alternative selection is a box in the lower-left corner of the wannabe box.  (On my other VL6 installation, that box contains "Master, 0".

Another issue that occurred at the same time is that the Quit -> Shutdown and Restart buttons are gray.  I have to log-off then use the login screen for those functions.

Is there a fix for this?  Or should I wipe the disk and reinstall?
« Last Edit: March 18, 2009, 03:58:38 pm by StrayBit »
Logged
Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: Blank Volume Control
« Reply #1 on: March 08, 2009, 08:17:09 pm »

Quote
that the Quit -> Shutdown and Restart buttons are gray.

That looks like a permissions problem. I can't remember exactly how I solved it when that happened to me, but I think I had been fooling arounf in /etc/sudoers and needed to replace the file.

Quote
When I click the speaker, it just gives an empty dialog window.

First thing to try would be to run "alsaconf" again. Then "alsamixer" when it finishes.
Logged

StrayBit

  • Vectorite
  • ***
  • Posts: 420
Re: Blank Volume Control
« Reply #2 on: March 08, 2009, 09:45:44 pm »

I had looked at sudoers a couple of times in 5.9  but didn't understand it so made no changes.  And it appeared untouched just now, unless something has uncommented several CMND_Alias lines.  And its permissions were ReadOnly for root and root group.

I had already tried .  Hadn't heard of but tried from terminal (after su) and what I found was expected.  It correctly specified card and driver as "ESS AudioDrive ES1869".  Cranked the Master volume up to 100% from about 90%.  The rest of the output settings looked satisfactory.  Clicking the speaker button next to the clock still gives an empty box as does it's properties.
Logged
Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: Blank Volume Control
« Reply #3 on: March 09, 2009, 10:41:15 am »

What about clicking in Settings > Mixer Settings and checking all the boxes for the devices?

Also, try starting xfce4-mixer from the terminal. You'd expect the same thing, give that it's the same program, but I've noticed that I got some more controls when I started it from the terminal.
That somehow "refreshed" the bars that show up when I click on the icon.
Logged

StrayBit

  • Vectorite
  • ***
  • Posts: 420
Re: Blank Volume Control[Solved]
« Reply #4 on: March 09, 2009, 12:28:53 pm »

The sound worked if I logged as root.  However, the Web Browser (both Seamonkey and FireFox) refused to start after the initial time.  Also the Quit buttons were still gray.

I've re-installed VL6 - the gui mode crashed while I was trying to set static IP, re-installed tui with no difficulty.

I noticed on login from either the crashed gui, or now, in the terminal the characters are multicolored, that is red on one edge and blue on the other.  Makes it difficult for me to read! (This only affects the terminal from xfce.)

User now has a filled Volume Control.  Master, Record, and Hardware are 0, everything else is 100.  I can move the 0 settings but they pop back to 0.  Settings > Mixer Settings and checking all the boxes for the devices added these devices to the Volume Control.

Logged in tui -> root.  Alsa mixer was on and I was able to increase the master volume to 100.  Also was OK after startx.  The restart button only returned to text mode - Ctrl-Alt-Del took care of that and I'm back as Bruce and sound works.

AlsaMixer from terminal indicates Master is [Off].  I could find nothing to change it.  According to the directions, 'M' was supposed to toggle it but didn't.  'N', 'P',
, and
scrolled appropriately, [Tab] changed the view at the top.

Now, to get the wheel to work, figure out the multi-colored terminal, and reinstall thunar-shares.  Then I'll be back to working out my network problems.
Logged
Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2305
Re: Blank Volume Control[Solved]
« Reply #5 on: March 09, 2009, 03:12:37 pm »

StrayBit: That must have been a permissions issue. Many of the problems you have been experiencing can be caused by that. Be careful about editing your configuration files as root, as you can accidentally change the permissions. If your user cant read or write the configuration files, you can have a lot of problems.

HTH
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

StrayBit

  • Vectorite
  • ***
  • Posts: 420
Re: Blank Volume Control[Solved]
« Reply #6 on: March 14, 2009, 07:01:23 am »

Wound up re-installing VL6.0 yet again.  I thought it was good this time.  No sound!  alsa-mixer shows Master at 0.  Mouse can move it but it pops back to zero.  Settings->Mixer can add/subtract controls.  Right-click Speaker->Properties Wannabe Master "Master,0".  Selected another setting: sticks but does not change alsa-mixer.  Returned it back to "Master,0".  Terminal->AlsaMixer returns "bash: AlsaMixer: command not found" either for Bruce or root.

Quote
StrayBit: That must have been a permissions issue. Many of the problems you have been experiencing can be caused by that. Be careful about editing your configuration files as root, as you can accidentally change the permissions. If your user cant read or write the configuration files, you can have a lot of problems.
I have edited NO sound configuration files directly, only by the methods specified.  I have no idea which files you are referring to.  I did find ~/.config/mixer.  It is read/write by owner bruce but I have made no direct edits to it.
Logged
Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: Blank Volume Control[Reopened]
« Reply #7 on: March 17, 2009, 01:01:10 pm »

Quote
Terminal->AlsaMixer returns "bash: AlsaMixer: command not found"

That should be "alsamixer" (no capitals).
Logged

StrayBit

  • Vectorite
  • ***
  • Posts: 420
Re: Blank Volume Control[Reopened]
« Reply #8 on: March 18, 2009, 04:35:40 am »

Thanks, wcs.  I copied/pasted from a previous post and picked the wrong one!
Quote
┌──────────────────[AlsaMixer v1.0.18 (Press Escape to quit)]──────────────────┐
│ Card: ESS AudioDrive ES1869                                                  │
│ Chip: ESS AudioDrive ES1869                                                  │
│ View: [Playback] Capture  All                                                │
│ Item: Master [Off]                                                           │
│                                                                              │
│    ┌──┐     ┌──┐               ┌──┐     ┌──┐      ┌──┐     ┌──┐     ┌──┐     │
│    │▒▒│     │▒▒│               │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│               │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│               │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     >
│    │▒▒│     │▒▒│               │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     >
│    │▒▒│     │▒▒│               │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     >
│    │▒▒│     │▒▒│               │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     >
│    │▒▒│     │▒▒│               │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     >
│    │▒▒│     │▒▒│               │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     >
│    │▒▒│     │▒▒│               │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│               │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    │▒▒│     │▒▒│               │▒▒│     │▒▒│      │▒▒│     │▒▒│     │▒▒│     │
│    ├──┤     └──┘      ┌──┐     └──┘     └──┘      └──┘     └──┘     └──┘     │
│    │MM│               │OO│                                                   │
│    └──┘               └──┘                                                   │
│  100<>100    100             100<>100 100<>100  100<>100 100<>100 100<>100   │
│ < Master >3D Contr  3D Contr   PCM     PCM 1       FM      Line      CD      │
└──────────────────────────────────────────────────────────────────────────────┘
Nothing that I have tried changes the status of "Item: Master".
Logged
Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2305
Re: Blank Volume Control[Reopened]
« Reply #9 on: March 18, 2009, 09:33:20 am »

Master is muted, select it and press "m" to unmute.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

StrayBit

  • Vectorite
  • ***
  • Posts: 420
Re: Blank Volume Control[Reopened]
« Reply #10 on: March 18, 2009, 12:00:44 pm »

I could find no way to select Item.  And 'M' did nothing.  Re-ran alsaconfig - no change.
Logged
Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2305
Re: Blank Volume Control[Reopened]
« Reply #11 on: March 18, 2009, 12:19:05 pm »

you select with the keyboard arrows. If you cant select them then there is something really serious with your terminal.
Logged
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!

StrayBit

  • Vectorite
  • ***
  • Posts: 420
Re: Blank Volume Control[Reopened]
« Reply #12 on: March 18, 2009, 01:32:45 pm »

Left/Right-arrow or n/p do allow me to select the channel and, as shown, Master is selected.  At this point, tab/shift-tab allow me to select playback | capture | all.  M | m | Ctrl-m | Ctrl-M do nothing, Alt-m quits.
Logged
Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Blank Volume Control[Reopened]
« Reply #13 on: March 18, 2009, 02:41:24 pm »

If you have amixer installed then you can probably explicity set the master volume and set it to unmuted:
ex) amixer -c 0 sset Master 70% unmute

The above will set the Master volume of your first audio card to 70% and unmute the mixer control.  Maybe this will help.
Logged

StrayBit

  • Vectorite
  • ***
  • Posts: 420
Re: Blank Volume Control[Reopened]
« Reply #14 on: March 18, 2009, 03:58:02 pm »

Quote
bruce:$ amixer -c 0 sset Master 70% unmute
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 63
  Mono: Capture [on]
  Front Left: Playback 45 [71%] [on]
  Front Right: Playback 45 [71%] [on]
Alsa-Mixer now displays about 75% volume.  Will try some audio - it works!

Thank you very much Newtor.
Logged
Dell GX280: [7.0-Gold-Final], 6.0-Gold-Final, 5.9-Gold
HP 670 Win7 & VL7.0
Pages: [1] 2