VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Swedish keymap .. impossible?  (Read 3824 times)

nicefinger

  • Member
  • *
  • Posts: 7
Swedish keymap .. impossible?
« on: March 08, 2009, 10:56:49 pm »

My vector is a nice experience .. but some errors are there that needs to be solved.
During install one could choose keymap. There is a box to test it. Swedish did not work .. I choosed default english and hoped to solve the problem later. But it seems hard.
You can not do it via GUI, not possible to add keymaps there. I tried to change xorg.conf but do not know exactly how.
Swedish keymap package seems broken.
From xorg.0.log
Quote
..
(EE) Error compiling keymap (server-0)
(EE) XKB: Couldn't compile keymap
(WW) Couldn't load XKB keymap, falling back to pre-XKB keymap
..
(WW) Option "XkbModel" requires an string value
(**) Option "XkbLayout" "se"
(**) Keyboard0: XkbLayout: "se"
(WW) Option "XkbVariant" requires an string value
..

Can someone get something out of that?
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: Swedish keymap .. impossible?
« Reply #1 on: March 08, 2009, 11:55:50 pm »

It's actually pretty easy to do in Xorg.conf.  Open the file in your favorite text editor as root.  Look for the line that reads:

Code: [Select]
Option  "XkbLayout"  "us"    ## KEYBOARD_MAP!
Change us to the correct code for Sweden (sv IIRC).  You'll need to logout of X.  The next time you start X you should have the correct keyboard layout.

HTH,
Cait
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

nicefinger

  • Member
  • *
  • Posts: 7
Re: Swedish keymap .. impossible?
« Reply #2 on: March 10, 2009, 09:00:57 am »

Eeeh .. I tried that .. was not that easy ..
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: Swedish keymap .. impossible?
« Reply #3 on: March 19, 2009, 11:28:36 pm »

Well... that did work for my Hebrew keyboard so I don't know what else to suggest.  Sorry...
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: Swedish keymap .. impossible?
« Reply #4 on: March 20, 2009, 11:43:29 am »

You can also try
Code: [Select]
setxkbmap -layout <your_keyboard_layout_here> [-model <your_keyboard_model_here]the -model option is optional

nicefinger

  • Member
  • *
  • Posts: 7
Re: Swedish keymap .. impossible?
« Reply #5 on: March 21, 2009, 12:04:49 pm »

Code: [Select]
nicefinger:$ setxkbmap -layout se
Error loading new keyboard description

No it does not work ....
Logged

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3234
Re: Swedish keymap .. impossible?
« Reply #6 on: March 21, 2009, 01:03:38 pm »

That's an upstream problem with xorg... not Vector.
Google that error message and see for yourself

nicefinger

  • Member
  • *
  • Posts: 7
Re: Swedish keymap .. impossible?
« Reply #7 on: March 21, 2009, 01:15:30 pm »

That's an upstream problem with xorg... not Vector.
Google that error message and see for yourself

Okeyyy .... I what can I do about it?
Logged

OldNoob

  • Member
  • *
  • Posts: 20
Re: Swedish keymap .. impossible?
« Reply #8 on: April 13, 2009, 03:15:04 am »

Hello mannen. Read this : http://forum.vectorlinux.com/index.php?topic=2595.0 ( open a terminal window,go root and type mc press enter and you got a nice filemanager with built in editor just go to to file and press F4 ) Try this and good luck!
Logged