VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Cant use Ctrl-Alt-Fn to switch to virtual terminal  (Read 3023 times)

Robert S

  • Member
  • *
  • Posts: 7
Cant use Ctrl-Alt-Fn to switch to virtual terminal
« on: February 12, 2009, 03:49:53 am »

I've done several installations of VL-6.0-rc1-4.  On each one I'm unable to use Ctrl-Alt-F1-7 to change virtual terminals.  What is happening here and how can I remedy this?
Logged

caitlyn

  • Packager
  • Vectorian
  • ****
  • Posts: 2878
    • The Linux Works
Re: Cant use Ctrl-Alt-Fn to switch to virtual terminal
« Reply #1 on: February 12, 2009, 09:11:22 am »

I just tried it on my rc4 build on my Sylvania netbook and it worked perfectly.  Perhaps it's an issue related to your specific hardware.  Are you on a notebook, laptop, or netbook?  If so, which model? 
Logged
eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: Cant use Ctrl-Alt-Fn to switch to virtual terminal
« Reply #2 on: February 12, 2009, 09:47:04 am »

The only thing I'm aware of that could cause this is if there is a line in xorg.conf that has the option "VTswitch" set to false (or something similar).

Although I doubt that a default X configuration would come like this, but check your /etc/X11/xorg.conf anyway...

In any case, you can try starting Vector in textmode (or run "init 2") and see if the problem continues.
At least, you'll be able to see if it's anything to do with X.

Also, check in your running processes if you have several "/sbin/mingetty" processes, to see if the terminals are even starting (or look at /etc/inittab to see if they are being launched).

If the problem is not in X and the processes are running, I'm out of ideas... Maybe something to do with your keyboard.
Logged

Robert S

  • Member
  • *
  • Posts: 7
Re: Cant use Ctrl-Alt-Fn to switch to virtual terminal
« Reply #3 on: February 13, 2009, 01:09:39 am »

Thanks for the useful comments.

Yes - /sbin/mingetty tty1,3,4,5,6 are in my process list.
Yes - switching to VTs works when I do "telinit 2"

I've used the default xorg.conf set up by VL.  This snippet might help:

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
Option  "XkbLayout"  "us"    ## KEYBOARD_MAP!
Option  "XkbModel"  ""    ## KEYBOARD_MODEL!
Option  "Xkbvariant"  ""    ## KEYBOARD_VARIANT!
EndSection

Its clearly an X problem.  At certain stages odd characters appear on the screen (in editor applications) when I hit Ctrl-Alt-Fn combinations.
Logged

linuxgeek

  • Member
  • *
  • Posts: 7
Re: Cant use Ctrl-Alt-Fn to switch to virtual terminal
« Reply #4 on: February 13, 2009, 08:12:28 am »

I don't have X up right now, but I think I recall that when in X, you have to include Shift, e.g. ctrl-alt-shift-F1.  Once you're in a console, you don't need the shift.
Logged

Robert S

  • Member
  • *
  • Posts: 7
Re: Cant use Ctrl-Alt-Fn to switch to virtual terminal
« Reply #5 on: February 13, 2009, 02:11:45 pm »

No luck with that  :'(

Then I hit ctrl-alt-F1 and I have a terminal window open, the characters ";7P" (without double quotes) appear in the terminal.  Don't know if that helps.
Logged

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: Cant use Ctrl-Alt-Fn to switch to virtual terminal
« Reply #6 on: March 09, 2009, 10:59:13 am »

The only difference from my xorg.conf keyboard section and yours is the following line:
Code: [Select]
Option  "XkbModel"  "pc105"
Give it a try...

(however, this is with a gb keyboard, not us)
Logged

Windozer

  • Vectorite
  • ***
  • Posts: 386
  • Have Vector Linux, Will Travel.
Re: Cant use Ctrl-Alt-Fn to switch to virtual terminal
« Reply #7 on: March 09, 2009, 06:29:25 pm »

I think I recall that when in X, you have to include Shift, e.g. ctrl-alt-shift-F1.  Once you're in a console, you don't need the shift.

No shift needed - do ctrl-alt+Fn

... I just tried it using both a usb and old-style (PS2) keyboards.

On Xfce, the initial gui is on F7 (it's probably the same on the other wm.)

If your keyboard has two sets of control and alt (meta) keys, try using each set or a combination. I know this sounds weird, but keyboards issue different scan codes for left and right (at least most of the time  ;) )

- H
« Last Edit: March 09, 2009, 06:41:47 pm by Windozer »
Logged
483,617th Registered Linux Snoozer