Please support VectorLinux!

Author Topic: rhythmbox  (Read 1042 times)

fox

  • Member
  • *
  • Posts: 38
rhythmbox
« on: March 10, 2009, 06:09:55 pm »
I'm trying to run rhythmbox in VL6.0 and when I start it up from a terminal, I get the following error: "rhythmbox: error while loading shared libraries: libcamel-1.2.so.11: cannot open shared object file: No such file or directory".  Libcamel doesn't seem to be in the VL repository.  How could that be when rhythmbox itself is in the repository.  If libcamel is a dependency, why wasn't it installed when I installed rhythmbox?
Mac user with Linux tendencies
Intel iMac 2.16ghz C2D; Mac mini 1.83ghz C2D
MSI Wind U100, 2ghz RAM, 80gb HD, Gigabyte atheros wireless
PowerBook G4/1.33 15" Al

rbistolfi

  • Packager
  • Vectorian
  • ****
  • Posts: 2299
Re: rhythmbox
« Reply #1 on: March 10, 2009, 06:51:37 pm »
Hi fox

libcamel is part of the evolution-data-server package and it is listed as a dependency for rhythmbox.

Code: [Select]
rbistolfi@vector [ ~ ] %grep -r libcamel-1.2.so.11 /var/log/packages
/var/log/packages/evolution-data-server-2.22.1.1-i586-1gsb:usr/lib/libcamel-1.2.so.11.0.0

Quote
rbistolfi@vector [ ~ ] %slapt-get --search --show rhythmbox | grep Required
Package Required:   GConf >= 2.22.0-i586-2gsb,ORBit2 >= 2.14.12-i586-2gsb,aaa_base >= 12.1.0-noarch-2 | glibc-solibs >= 2.7-i486-10,alsa-lib >= 1.0.18-i586-1vl60,atk >= 1.22.0-i486-1,audiofile >= 0.2.6-i486-2,avahi >= 0.6.22-i586-3gsb,cairo >= 1.6.4-i586-1vl60,cxxlibs >= 6.0.9-i486-1 | gcc-g++ >= 4.2.3-i486-1,db44 >= 4.4.20-i486-2,dbus >= 1.1.20-i486-1,dbus-glib >= 0.74-i486-2,e2fsprogs >= 1.40.8-i486-1,esound >= 0.2.38-i486-1,evolution-data-server >= 2.22.1.1-i586-1gsb,expat >= 2.0.1-i486-1,fontconfig >= 2.4.2-i486-2,freetype >= 2.3.7-i586-1vl60,gail >= 1.22.1-i586-1gsb,gcc >= 4.2.3-i486-1,glib2 >= 2.16.3-i586-1gsb,gnome-keyring >= 2.22.1-i586-1gsb,gnome-media >= 2.22.0-i586-3gsb,gnome-vfs >= 2.22.0-i586-2gsb,gnutls >= 2.2.5-i486-1_slack12.1,nss >= 3.11.9-i586-2gsb,gst-plugins-base >= 0.10.19-i586-1gsb,gstreamer >= 0.10.20-i586-1vl60,gtk+2 >= 2.12.9-i486-1,hal >= 0.5.10-i486-2,heimdal-libraries >= 1.1-i586-2gsb,libICE >= 1.0.4-i486-1,libSM >= 1.0.3-i486-1,libX11 >= 1.1.4-i486-1,libXau >= 1.0.3-i486-1,libXcomposite >= 0.4.0-i486-1,libXcursor >= 1.1.9-i486-1,libXdamage >= 1.1.1-i486-1,libXdmcp >= 1.0.2-i486-1,libXext >= 1.0.4-i486-1,libXfixes >= 4.0.3-i486-1,libXi >= 1.1.3-i486-1,libXinerama >= 1.0.3-i486-1,libXrandr >= 1.2.2-i486-1,libXrender >= 0.9.4-i486-1,libart_lgpl >= 2.3.20-i486-1,libbonobo >= 2.22.0-i586-2gsb,libbonoboui >= 2.22.0-i586-2gsb,libgcrypt >= 1.4.0-i486-2,libglade >= 2.6.2-i486-2 | libglade >= 2.6.2-i586-1gsb,libgnome >= 2.22.0-i586-2gsb,libgnomecanvas >= 2.20.1.1-i586-2gsb,libgnomeui >= 2.22.1-i586-1gsb,libgpg-error >= 1.6-i486-3,libjpeg >= 6b-i486-5,libmusicbrainz >= 2.1.5-i586-1gsb,libnotify >= 0.4.4-i586-2gsb,libpng >= 1.2.29-i586-1vl60,libsexy >= 0.1.11-i586-2gsb,libsoup >= 2.4.1-i586-1gsb,libusb >= 0.1.12-i486-2,libxcb >= 1.0-i486-2,libxml2 >= 2.6.31-i486-2,nautilus-cd-burner >= 2.22.1-i586-1gsb,openssl >= 0.9.8h-i486-1_slack12.1 | openssl-solibs >= 0.9.8h-i486-1_slack12.1,pango >= 1.20.0-i486-1,pixman >= 0.10.0-i486-4,popt >= 1.7-i486-2,python >= 2.5.2-i486-1,rhythmbox >= 0.11.5-i586-4gsb,totem-pl-parser >= 2.22.2-i586-1gsb,zlib >= 1.2.3-i486-2

I just installed it and slapt-get pulled from the needed deps. Not sure why it didn't work for you. Check your Gslapt configuration and be sure you have the proper SOURCES enabled, you may find some clue in the system logs, specially /var/log/packages and /var/log/pkgtools.
You could try a reinstall for rhythmbox or simply installing the missing dep.

HTH
"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!