VectorLinux
April 24, 2014, 12:03:50 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: X server problem installing on Thinkpad T21  (Read 1268 times)
roxburd
Member
*
Posts: 12


« on: March 17, 2009, 01:07:30 am »


Hey, I installed last night (it took ALL night!).

When it started up first time it did some more first-run config like setting up the display resolution. It asked me if I wanted to select from a list of options or use 'AUTO (no questions)'. Being lazy/dumb, I went for that one!

It then seemed to find my display details... it then fell over with an error in /var/log/Xorg.0.log - apparently, there are no devices listed in /etc/X11/xorg.conf

Now, I do have a little experience in RedHat/Fedora/Solaris and I figured that if I could get to a term I could have a poke around, maybe use vasm/vasmCC to put things right. [I have no idea what vasm/vasmCC is but the start-up mention that I might wanna poke around the config with them]

But what happens is that start-up gets as far as the X server falling over because of the above, then it just hangs on the start-up progress bar screen. If I press ESCAPE (I think) I get a blue screen with some start-up trace, a border and the VL logo in the lower-right. And a prompt. I can type in to that prompt but it seems to print but then ignore (i.e. just echo) absolutely any input.

Any pointers on how to get past this blue screen of pergatory very much appreciated. Further pointers on correcting the X config also much appreciated.

Incidentally, I'm also fascinated by the 10 second count-down right at the start of boot... if I stab at the right key (and it is a guess) I can get to a boot: prompt. And if I guess right again I can get what looks like a list of start-up profiles... a list of 1 - VectorLinux. Am I right? I'm getting a 10 second delay in boot in order to give the the chance to confirm that I do in fact want the only choice from the list of 1???

Any help much appreciated.

Dave
Logged
nightflier
Administrator
Vectorian
*****
Posts: 3942



« Reply #1 on: March 17, 2009, 04:42:36 am »

Your LILO installation is not at defaults. You normally have three choices during the 10 second wait: Normal, GUI and TUI (text mode).

Try booting off your CD again, but instead of just hitting Enter when it asks you, enter:
linux root=/dev/XXX 2 ro
substitute the location of your install (hda1, sda3 or whatever) for the "XXX"

If all goes well, you should get a text mode login prompt. Log in as root and issue command "vasm". Look around in the options. One thing I would highly recommend is to run LILO install again and make sure the TUI option is included. Next you can try x-windows configuration again, going through the manual steps instead of "auto".
Logged
rbistolfi
Packager
Vectorian
****
Posts: 2265


« Reply #2 on: March 17, 2009, 04:51:56 am »

Hi roxburd.

When the boot process stops, press Control + Alt + F2 to see if that gives you a virtual terminal.
Login as root and use the vxconf command to get the X server configuration again. I always have better luck using "vxconf" (the first entry in the menu iirc) than "auto", and it is very easy anyway.
A command that can be useful for troubleshooting is lspci, it will list the devices in your computer including your VGA chip. If you can give us the output of

lspci | grep VGA

we could try to get a good driver for your card, and configure the server in case vxconf fails again.

Regards, Rodrigo.

EDIT: Nightflier beat me, I think both answers are complementary, so I leave this anyway Smiley
Logged

"There is a concept which corrupts and upsets all others. I refer not to Evil, whose limited realm is that of ethics; I refer to the infinite."
Jorge Luis Borges, Avatars of the Tortoise.

--
Jumalauta!!
roxburd
Member
*
Posts: 12


« Reply #3 on: March 17, 2009, 05:18:11 am »

Your LILO installation is not at defaults. You normally have three choices during the 10 second wait: Normal, GUI and TUI (text mode).

Try booting off your CD again, but instead of just hitting Enter when it asks you, enter:
linux root=/dev/XXX 2 ro
substitute the location of your install (hda1, sda3 or whatever) for the "XXX"

If all goes well, you should get a text mode login prompt. Log in as root and issue command "vasm". Look around in the options. One thing I would highly recommend is to run LILO install again and make sure the TUI option is included. Next you can try x-windows configuration again, going through the manual steps instead of "auto".

Hi Chaps, thanks for your help. I wish I'd waited an hour before I tried re-installing - it's whirring away as I type.

Before I started the re-install, I tried the "linux root=/dev/XXX 2 ro" option you mention. Boot proceeded as before except I could see the boot trace as it happened (the same trace I could see the tail of on the blue-bordered screen I mentioned before). The trace ended the same - switching display off, prompt echoing but ignoring input.

Dave

Logged
nightflier
Administrator
Vectorian
*****
Posts: 3942



« Reply #4 on: March 17, 2009, 05:49:32 am »

Sounds like a frame buffer problem. When you install LILO, choose the "standard" (safest) option, rather than one of the splash screens.
« Last Edit: March 17, 2009, 06:04:24 am by nightflier » Logged
lagagnon
Global Moderator
Vectorian
*****
Posts: 1922



WWW
« Reply #5 on: March 17, 2009, 08:03:15 am »

At the boot screen you should have an option "linux-tui". Choose that. Login as root. Type "vasm". Rerun "xwindow" and see if you cannot get the X server configured properly again. Get out of vasm once this is done and type "startx". What happens? If still errors post the output of the following commands to this thread so we can help you further:

cat /etc/X11/xorg.conf
lspci
lsmod

At the initial boot screen, if you installed lilo, you should have a couple of options. You can change the timeout to < 10 seconds by editing "/etc/lilo.conf" and then rerunning "lilo -v" as root.
Logged

"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll
Irritated
Member
*
Posts: 21


« Reply #6 on: March 17, 2009, 08:54:17 am »

Hi Dave

Did you read my posts Boot to Black Screen etc? The guys have been helping me on this one. You might find some useful bits in there? Or not as the case may be Wink

J
Logged
roxburd
Member
*
Posts: 12


« Reply #7 on: March 18, 2009, 05:31:03 am »


Thanks for all your help guys,

I did a freash install and chose xvconf to set up X. It all worked beautifully! I am impressed! Very impressed to be truthful. VL detected my Atheros PCMCIA WiFi card and the WLAN setup is the best I've ever known - it was almost telepathic! And USB drive detection and access was equally smooth. Really nice.

Nice one.

Dave
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!