VectorLinux
April 24, 2014, 12:15:23 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Problem with my USB  (Read 1215 times)
terco99
Member
*
Posts: 5


« on: March 22, 2009, 06:51:36 pm »

Hi, i've got a problem, whenever i insert an USB memory in my laptop, this message apears:

mount: wrong fs type, bad option, bad superblock on /dev/mmcblk0p1,       
missing codepage or other error     
In some cases useful info is found in syslog - try       
dmesg | tail  or s
o  .

This didn't happened some days ago, I don't know why this began to happen, somebody help me  Sad  :S
Logged
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« Reply #1 on: March 23, 2009, 04:42:06 pm »

I am not sure if this has anything to do with your problem but... Which program are you using to mount devices? VL-Hot or HAL?
Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
terco99
Member
*
Posts: 5


« Reply #2 on: March 26, 2009, 08:34:42 pm »

i think that vl hot
Logged
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« Reply #3 on: March 27, 2009, 06:36:29 pm »

I have had problems with usb drives before while using VL-HOT. I switched to HAL and everything was fine. If you want to switch to HAL, go into VASM, Hardware, Mounter. It will then give you an option of whether to use VL-Hot or HAL.
Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
AMAMH
Member
*
Posts: 6


« Reply #4 on: March 28, 2009, 12:00:58 pm »

I assume usb format is ntfs.
open root terminal and type:

fdisk -l # this will list available partitions, usb should be /dev/sdb1
mkdir /media/tmpdrive
mount -t ntfs-3g -o allow_other /dev/sdb1 /media/tmpdrive
if that doesn't work try different format other than ntfs-3g if that also doesn't work then try forcing it with:
mount -t ntfs-3g (or whatever format) -o force,allow_other /dev/sdb1 /media/tmpdrive

if that worked then probably the problem was that the last time u removed the usb u didn't make a safe remove or windows shutdown suddenly or something like that
based on the error message that u get I think u will not need to use mount -o force, the problem is that u need to specify partition type with -t ntfs-3g (or whatever format)

btw, I get this message a lot, it's not a big deal
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!