Please support VectorLinux!

Author Topic: Microsoft Mouse - Scroll not working  (Read 3492 times)

kedarm

  • Member
  • *
  • Posts: 28
Microsoft Mouse - Scroll not working
« on: March 23, 2009, 11:18:24 pm »
Hi!

I've just converted to Vector Linux from Ubuntu (more on the trying out phase, I must admit).

I use a USB mouse (Microsoft). However, I find that the scroll doesn't work. It is very inconvenient. Is tehre some setting I need to enable somewhere?

I'd realy like to get it working asap.

Thanks
Kedar

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: Microsoft Mouse - Scroll not working
« Reply #1 on: March 24, 2009, 08:32:57 am »
1. You could go into the Vasm control center and under hardware you will find a utility to help configure your mouse.

I just tested it by resetting my Microsoft laser mouse 6000 (usb of course).  Just used 'Auto detect' then selected the appropriate options from the prompts. 


Hopefully someone will come around that can give you a little more advice than that.  The only time I've had trouble with scrolling is when I've been connected through a KVM switch.

Good luck.
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

kedarm

  • Member
  • *
  • Posts: 28
Re: Microsoft Mouse - Scroll not working
« Reply #2 on: March 25, 2009, 05:43:54 am »
I went into VASM Control Center and under hardware, chose the "keyboard, mouse, etc" utility. I chose USB mouse and it gave me an option of "two buttons and wheel".

I chose the "two button and wheel" option, but there is still no change. The wheel is still not being detected.

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: Microsoft Mouse - Scroll not working
« Reply #3 on: March 25, 2009, 08:53:21 am »
Well, I believe you.  I just tried to do the opposite.  I selected VASM > Hardware > mouse
and selected a two button mouse trying to make my scroll not work.
I thought maybe I had to restart the x-server to get the new setting to take effect, but no matter what I did the scroll always worked. So maybe we should try something else as the the advice I first gave does not seem to work.

Could you post your xorg.conf line for your ServerLayout and mouse.  Go to /etc/X11/ then open xorg.conf with mousepad.

Mine looks like this...
Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option       "Protocol" "auto"
Option       "Device" "/dev/input/mice"
Option       "ZAxisMapping" "4 5"

Also, did you set-up so that you can launch into the text user interface from your boot screen?
If so maybe I can take you through some VASM utilities while the x-server is not running.
If not I'll just have to get you to set up to launch into text mode.

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

kedarm

  • Member
  • *
  • Posts: 28
Re: Microsoft Mouse - Scroll not working
« Reply #4 on: March 25, 2009, 10:04:01 am »
This is the 'ServerLayout' section of my xorg.conf (I've removed the commented sections)
Quote
Section "ServerLayout"
    Identifier  "Simple Layout"
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection

and "InputDevices" section (I've removed the commented sections)
Quote
Section "InputDevice"
    Identifier   "Mouse1"
    Driver   "mouse"
    Option "Protocol"    "PS/2"
    Option "Device"      "/dev/mouse"
    # Option   "ZAxisMapping"      "4 5"
EndSection
I tried with and without commenting the last line (ZaxisMapping), but it didn't work.

After any change, I logout and restart xserver to see if the changes have come into place, but I've not had much luck!

I have set up Vector Linux such that I always start into text mode and need to manually start xserver (with a 'startx') to get it working. I prefer working in the command line and use the x to view pdfs (images) and check mail (not familiar with mail clients).

However, a scroll not working can be a major pain! Thanks for all the patience and the help.

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: Microsoft Mouse - Scroll not working
« Reply #5 on: March 25, 2009, 10:15:03 am »
I googled your Option "Protocol"  "PS/2"
and got this result
http://www.xfree86.org/current/mouse6.html

I found this line interesting from the document.
To use this mouse as the PS/2 device but the OS does not support PS/2 mouse initialization (the wheel won't work in this case):

   Option   "Protocol"   "PS/2"

I think you are better to edit this line to...
Option   "Protocol"   "Auto"

There are several options given some for specific microsoft mice.  Hope you find your answer there.
Ken

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

bigpaws

  • Vectorian
  • ****
  • Posts: 1868
Re: Microsoft Mouse - Scroll not working
« Reply #6 on: March 25, 2009, 03:18:10 pm »
Quote
Option "Device"      "/dev/mouse"
    # Option   "ZAxisMapping"      "4 5"

You need to be root to edit this file.

First the # is called a comment delete that character,

then try starting x.

If that fails then try changing /dev/mouse to /dev/input/mice.

HTH

Bigpaws


kedarm

  • Member
  • *
  • Posts: 28
Re: Microsoft Mouse - Scroll not working
« Reply #7 on: March 25, 2009, 06:22:12 pm »
@ stretchedthin :

Thanks a lot! The scroll is working now. In fact, the required line is present, but has been commented out. I uncommented it and restarted x, and everything works exactly the way I want it!


@ bigpaws :

I had tried uncommenting that line but I never had any success. But, out of curiosity, what does ZAxisMapping erally do? A lot of sites gave that as the solution, did not understand exactly what it does.

Thanks
Kedar

bigpaws

  • Vectorian
  • ****
  • Posts: 1868
Re: Microsoft Mouse - Scroll not working
« Reply #8 on: March 25, 2009, 06:25:01 pm »
ZAxisMapping defines wat buttons are used on the mousewheel.

Bigpaws