VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: mplayer can't play video files  (Read 1877 times)

triyanto

  • Member
  • *
  • Posts: 10
mplayer can't play video files
« on: March 24, 2009, 08:29:50 am »

I'm using VL 5.9. It runs smoothly on my Tecra 8000 laptop with proc. 266 and RAM 128. Unfortunately, when I try mplayer to play some video files (e.g avi, mpeg, flv, etc) in graphic mode it is failed. Still in graphic mode, I can play the files only on xine, but it run so slowly.
Then, I try to play in console mode, without any x server active, mplayer runs smoothly. But, I can't change the resolution, the video always appears in fullscreen mode.
What's wrong with this? 
Logged

overthere

  • Vectorian
  • ****
  • Posts: 1333
Re: mplayer can't play video files
« Reply #1 on: March 25, 2009, 06:13:56 am »

Hi
perhaps low ram is issue and not running the xserver adds resource..you may try disable scaleing under video in xine settings/ setup...perhaps other settings may help also like enable drop frames or buffer size... if you are playing from a cd or dvd drive you may require dma to be turned on...in terminal as root hdparm -d 1 /dev hd(x) where (x) is the drive in question...if you are useing vesa rather than xorg that may also add to the issue..hope that helps a little
cheers
Logged
Everything Is Relative

bigpaws

  • Vectorian
  • ****
  • Posts: 1869
Re: mplayer can't play video files
« Reply #2 on: March 25, 2009, 04:42:00 pm »

Here is something to try.

Open a terminal, then use su and type in your root password.

Now type:

echo 1024 > /proc/sys/dev/rtc/max-user-freq

Now try your video.

If that works add that command to the bottom of /etc/rc.d/rc.local, you
need to be root to edit that file.

Bigpaws
Logged

triyanto

  • Member
  • *
  • Posts: 10
Re: mplayer can't play video files
« Reply #3 on: March 25, 2009, 08:34:40 pm »

Thnx all,
I'll try those ways. Lack of RAM, what about increasing its swap memory? Is it helpful?
Logged