VectorLinux
August 19, 2014, 10:25:28 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: cannot change background image  (Read 2677 times)
gregorydearth
Member
*
Posts: 5


« on: March 25, 2009, 10:01:30 am »

I can change the wallpaper in kde and xfce. but when I change it in fluxbox or jwm it changes back to rockface (default) when I reboot! it does not reset in kde or xfce. this problem only shows up in jwm or fluxbox window managers. I would rather use fluxbox for its speed on my old computer. even xfce is a bit sluggish and kde is nearly unusably slow. help please!
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: March 25, 2009, 10:35:53 am »

I don't use fluxbox but if it uses the PCMan file manager you may be able to change your background image there.

Go to edit > preferences > Desktop   There you can make your wallpaper choice.

I've seen this work in lxde and icewm. let me know how it goes.

Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
gregorydearth
Member
*
Posts: 5


« Reply #2 on: March 25, 2009, 01:41:58 pm »

actually the tool that replaces the wallpaper is easy to use. it works. but if I reboot the image changes back to rockface. in damn small linux (fluxbox) I had the same problem. the way I fixed it in dsl was to make the opt and home folders replicate to a third partition (see persistence). but vector uses only two partitions, the swap and the main bootable type 83. should I have set up vector with a third partition to ensure persistence? or is something else to blame?
Logged
caitlyn
Packager
Vectorian
****
Posts: 2874


WWW
« Reply #3 on: March 25, 2009, 01:53:21 pm »

Vector Linux isn't Damn Small Linux.  Everything is persistent and saved to the hard drive unless you are running a Live CD.  You didn't way which version of VL you are running.  Telling us that would be really helpful.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
overthere
Vectorian
****
Posts: 1268



« Reply #4 on: March 25, 2009, 03:28:21 pm »

Hi
you may be useing VL5.9-? as you mention rockface, fluxbox and jwm...you may try...

view/hidden files in the file manager and open
 .fluxbox
startup=  #fbsetbg -f /path/to/wp.jpg..remove # add /path/to/wp
overlay= background.pixmap: /path/to/wp.jpg..change /path/to/wp

.jwmrc
scroll down to line 230 odd..
<desktop count="2">
<Background type="image">/usr/share/wallpapers/?.jpg</Background>...?=your wallpaper..as root copy your wallpaper to /usr/share/wallpapers

hope that helps
cheers
« Last Edit: March 25, 2009, 03:31:51 pm by overthere » Logged

Everything Is Relative
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #5 on: March 25, 2009, 03:30:55 pm »

I don't use fluxbox but if it uses the PCMan file manager you may be able to change your background image there.

Go to edit > preferences > Desktop   There you can make your wallpaper choice.

I've seen this work in lxde and icewm. let me know how it goes.

Ok so I downloaded fluxbox with gslapt, changed my desktop manager to kdm so I could choose it as a session and I'm now using fluxbox, and yes the background image is just an ugly yellow-gold.  I see why you want to change it.

So, I gave my above suggestion a try.
I used the 'Run' utility from the menu and entered pcmanfm. 
It gives a warning that the GTK+ icon them is not set...just ignore it and click OK.

I go to edit > preferences > Desktop
There I select all 3 checkboxes so that pcmanfm manages the desktop and shows the fluxbox menu on right click.

I browse and choose my background picture from /usr/share/wallpapers
Click ok and just like that I have a new background (much better)

pcman remembers the background choice has to be started to do so.  So here is the trick to getting it to work everytime.

Go to /.fluxbox it is a hidden file in your user directory.
There there is a text file called startup. Open it with mousepad or the like.
 There is a section in it that looks like this...
# Applications you want to run with fluxbox.
# MAKE SURE THAT APPS THAT KEEP RUNNING HAVE AN ''&'' AT THE END.
#
# unclutter -idle 2 &
# wmnd &
# wmsmixer -w &
# idesk &
pcmanfm & (<---add this line here and save. It will start pcmanfm when you start fluxbox.)

Now you can easily change your background and it will reappear each time.

Now to get rid of that pesky warning.

Open .gtkrc-2.0 (this is another hidden text file in your user directory.
add this line to the top of it and save.
gtk-icon-theme-name="Tango"

That should do it.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
overthere
Vectorian
****
Posts: 1268



« Reply #6 on: March 25, 2009, 03:40:18 pm »

how do you get fluxbox to show on the session list in VL6-std? it has gdm and xdm but switch to xdm changes nothing...opps sorry

hope something here helps change the background wallpaper
cheers
« Last Edit: March 25, 2009, 04:18:15 pm by overthere » Logged

Everything Is Relative
caitlyn
Packager
Vectorian
****
Posts: 2874


WWW
« Reply #7 on: March 25, 2009, 04:37:40 pm »

A fluxbox.desktop file has to be added to /usr/share/xsessions.  It is missing in the package.  You can copy and modify on of the other .desktop files in that directory.
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #8 on: March 25, 2009, 05:47:25 pm »

how do you get fluxbox to show on the session list in VL6-std? it has gdm and xdm but switch to xdm changes nothing...opps sorry

hope something here helps change the background wallpaper
cheers
I had to switch to kdm to get fluxbox as a session choice.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
overthere
Vectorian
****
Posts: 1268



« Reply #9 on: March 25, 2009, 06:46:13 pm »

this is naturally not an option perhaps I need to install kde or buy the deluxe to get the option then install fluxbox...lol
I added a file Fluxbox to /usr/share/xsessions and rebooted. switched back to gdm rebooted. I have no issue installing the package to Light6..it appears in the session list
so the solution is shut down vl6-std boot Light and releave my frustration..what a maroon..What an ignoranamus..

This is not about me it is about gregorydearth setting the fluxbox and jwm wallpapers..hope something above helped
cheers
« Last Edit: March 25, 2009, 06:48:51 pm by overthere » Logged

Everything Is Relative
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #10 on: March 25, 2009, 07:14:06 pm »

Overthere.  I use 6.0 standard not the kde version.  To get kdm as an option just add KDEbase via gslapt.  I didn't mention it because gregorydearth never complained about launching fluxbox he seems to be doing that just fine. Maybe he even found his own way.
Ken
« Last Edit: March 25, 2009, 07:16:18 pm by stretchedthin » Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
overthere
Vectorian
****
Posts: 1268



« Reply #11 on: March 25, 2009, 07:29:57 pm »

Hmm oh so adding kdebase....what is that 250 megs...to add a lighter window manager to the sessions list...that would be rather amuseing..I am useing Light, perhaps it will get sorted out later I can wait..well until a distro comes along that I want to play with and install it to the vl6 box..I'm shutting up now about vl6 and fluxbox..sorry
cheers
Logged

Everything Is Relative
gregorydearth
Member
*
Posts: 5


« Reply #12 on: March 26, 2009, 04:58:28 am »

I figured there were some hidden files to edit. I seem to remember doing that months ago when I had installed vector. I switched to dsl for a while since it has a tool to change the background and is debian based. runs really fast on my 166mhz laptop! but vector is just too cool. so I switched back. rather than editing hidden files I now just rename the image file I want to use as rockface and store it in the same directory. I then rename rockface to rockface1 or something. it works. not as 'real' though. I downloaded vector about two weeks ago (lost my original disk). it came with flux, jwm, xfce and a few other wms. I used gslap to get kde (works beautifully on my server but slow on the laptop). hope vector takes notice and adds a tool to fluxbox to change backgrounds. editing hidden files is terribly tedious! especially when there are three that need to be edited! xfce works well enough on the 166mhz laptop so i'll just stick with that. I love how vector gives you an abundance of wm's to try. it really spans different computers from mmx pentiums to dual-cores and beyond.
Logged
overthere
Vectorian
****
Posts: 1268



« Reply #13 on: March 26, 2009, 02:41:37 pm »

fluxbox is no longer included with vl6 and light but is available in the repository uncustomized for vector.

you may try this:
go to /home/user/.fluxbox
create a file named overlay and add this content and save:

background: aspect  | tiled | centered
  background.pixmap:  /path/to/wallpaper.jpg
 
  change path to wallpaper with a path ie /home/user/wallpapers/sweet.jpg
 
  you can store the wallpaper anywhere, mine are in a folder in the home dir.
 
  add this line to the fluxbox menu

[exec] (Set Background) {adie ~/.fluxbox/overlay}

it will open a text editor of choice..in this case adie and you can change the path to a different wallpaper.

I think thats all I did to light6
hope it helps
cheers
Logged

Everything Is Relative
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!