VectorLinux
November 01, 2014, 02:06:07 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: boot-problem; VL5.9 Light  (Read 1187 times)
Sonic
Member
*
Posts: 13


« on: March 30, 2009, 09:22:06 am »

hi all,
first of all i want to mention that i'm not very experienced with linux.

my problem is as follows:
i boot from cd and setup works fine. it's just very slow... especially the process of "making swap partition" and copying files. that needs very long time, but maybe that's normal^^
also my hard drives are detected and all seems to work fine, but when it comes to boot my brand new installed vectorlinux i get an error.
when booting from lilo the standard decision (gui for desktop), and even under tui, it starts booting until i can see following lines:

TuxOnIce: Resume= parameter is empty. Hibernating will be disabled.
VFS: Cannot open root device "1601" or unknown-block(22,1)
Please append a correct "root=" boot option; here are the available partitions:
0340   4194302 hdb driver: ide-cdrom
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(22,1)

nothing works anymore. if i boot with the boot-option "2.6.22.19" all seems to work fine. vectorlinux starts and i can log in.

has anyone an idea how to solve that problem?

if you need information about the hardware i use, you can see my computer-profile here:http://www.sysprofile.de/id68703
this page is in german but i think you'll understand most of the importend things ;-)


Sonic
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #1 on: March 30, 2009, 10:54:58 am »

VL 5.9 Light comes with two different kernels, so as to be compatible with more hardware. Your machine obviously prefers one over the other. What you need to do is make that one the default choice.

Open up the file /etc/lilo.conf in a text editor, copy the contents of it and paste it into a reply here. We'll modify it to make the desired changes.

Or, if you are still in the early stages of experimentation, re-install and de-select the optional kernel package.
« Last Edit: March 30, 2009, 10:56:39 am by nightflier » Logged
Sonic
Member
*
Posts: 13


« Reply #2 on: March 30, 2009, 11:26:07 am »

thank you for the help.
yes, i'm still in the early stages of experimentation. i'll re-install and deselect the optional kernel package.

Sonic

*edit*
it works now after i re-installed it and deselected the optional kernel package.
« Last Edit: March 30, 2009, 03:33:34 pm by Sonic » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!