VectorLinux
April 16, 2014, 08:18:42 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: 090329 firefox-3.0.8 [VL6.0]  (Read 3503 times)
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« on: March 29, 2009, 11:23:22 am »

I've built firefox for VL 6.0. 

Package: firefox-3.0.8-i586-1vl60.tlz
MD5: df5f4897d0733c39bf21dcd4c7ff5d96
Package Size: 7286 K 
Installed Size: 25440 K

Sources:  http://vectorlinux.osuosl.org/veclinux-6.0/source/testing/x-apps/firefox

Code:
firefox: Firefox (Mozilla Firefox Web Browser)
firefox:
firefox: Firefox 3 is the next generation release of the award-winning
firefox: Firefox web browser from Mozilla.
firefox: To comply with Mozilla trademarks, and to assure quality control,
firefox: this is the official Mozilla build, packaged for VectorLinux.
firefox:
firefox:
firefox: License: MPL 1.1/GPL 2.0/LGPL 2.1
firefox: Author:  Mozilla Foundation <drivers@mozilla.org>
firefox: Website: http://www.mozilla.com/en-US/firefox/

Note this is a security fix update. For details of the update, see here:

http://www.mozilla.org/security/known-vulnerabilities/firefox30.html

After testing this package please stop back here and let us know how it works for you.

Logged
nightflier
Administrator
Vectorian
*****
Posts: 3939



« Reply #1 on: March 29, 2009, 04:41:40 pm »

Gslapt shows two packages of the same version.

The gsb dependencies remain. On Light, it wants to pull in another 14 packages. Ignoring deps, installed manually on two machines. Looks good so far.
« Last Edit: March 29, 2009, 05:36:58 pm by nightflier » Logged
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #2 on: March 29, 2009, 05:53:27 pm »

Gslapt shows two packages of the same version.

Whoops. Thanks - I'll check that when I can get at the repo again.

Quote
The gsb dependencies remain. On Light, it wants to pull in another 14 packages. Ignoring deps, installed manually on two machines. Looks good so far.

Smiley Time I looked at modifying the build script to see if I can dump those extras. Don't have the space for a light install as well as the others at the moment...

Thanks for testing.

paul.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 3939



« Reply #3 on: March 30, 2009, 10:59:16 am »

Another weird thing. After installing, gslapt gets it backwards and wants to UPGRADE 3.0.8-i586-1vl60 to 3.0.7-i586-1vl60.

And, the .desktop file is missing from /usr/share/applications.
« Last Edit: March 30, 2009, 11:03:24 am by nightflier » Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« Reply #4 on: March 30, 2009, 12:47:34 pm »

The gslapt upgrade thing can be resolved by removing the tag keywords from your slapt-getrc file. I found this annoying and also, that I had newer software in my box, yet the updated insisted that I UPGRADED to an older version....

Anyway, that's how you get rid of the annoyance with the updater.
Logged

toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #5 on: March 30, 2009, 12:59:21 pm »

Another weird thing. After installing, gslapt gets it backwards and wants to UPGRADE 3.0.8-i586-1vl60 to 3.0.7-i586-1vl60.

Doing the same to me. I have no idea why...

Quote
And, the .desktop file is missing from /usr/share/applications.

Thanks. I've fixed it and put it up again. Haven't incremented the build number, since I don't have time to upload all the language pack files again at the moment. Had the same problem with the 5.9 build, also fixed.

Thanks for testing...

paul.
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #6 on: March 30, 2009, 04:08:16 pm »

I upgraded today and have had no problems.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
nightflier
Administrator
Vectorian
*****
Posts: 3939



« Reply #7 on: March 30, 2009, 06:33:42 pm »

Thank you for removing the gsb dependencies!  Grin

Now, don't want to be a pest, but there is one minor one left.. it shows it needs cups >= 1.3.9-i486-1>slack12.1, which I suspect is unnecessary.

On that note, I don't see cups in the repo, will post a request for that.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 3939



« Reply #8 on: March 31, 2009, 08:10:14 am »

Disregard above comment about gsb deps. I got myself totally confused now. I tried building and installing FF3.1b3 (looks good so far), but glapt wants to "upgrade" that one to 3.0.7 as well.

It looks like 3.0.7 is the dominant version around. Could this have anything to do with the xulrunner experiment?
Logged
uelsk8s
Administrator
Vectorian
*****
Posts: 2503



« Reply #9 on: March 31, 2009, 12:34:05 pm »

Disregard above comment about gsb deps. I got myself totally confused now. I tried building and installing FF3.1b3 (looks good so far), but glapt wants to "upgrade" that one to 3.0.7 as well.

It looks like 3.0.7 is the dominant version around. Could this have anything to do with the xulrunner experiment?

I think this has to do with the patches repo having a higher priority than the testing repo.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 3939



« Reply #10 on: March 31, 2009, 05:43:10 pm »

Understand. Considering that 3.0.8 is a security update, I think we should expedite its migration out of testing.

So for the record; my previous whining aside, the package installs and works well. I have not had any problems or noticed anything out of the ordinary.
Logged
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #11 on: April 01, 2009, 04:56:04 am »

Understand. Considering that 3.0.8 is a security update, I think we should expedite its migration out of testing.

Done. Along with Seamonkey, which falls into the same category, and works fine for me...

Quote
So for the record; my previous whining aside, the package installs and works well. I have not had any problems or noticed anything out of the ordinary.

 Grin

paul.
Logged
vincent2
Vectorite
***
Posts: 388


« Reply #12 on: April 01, 2009, 11:42:03 pm »

Bonjour!
Tried to update to firefox-3.0.8|[VL6.0] under gslapt , but failed., it prompted as:
"firefox: Depends: libxcb >= 1.1.91-i486-2vl60"

which means missing dependencies., only found "libxcb-1.1.91" packages under VL6.0 testing tree, should I risk updating libxcd in VL6.0 testing tree?
     
 a bien tot
Logged
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #13 on: April 02, 2009, 03:56:27 am »

Bonjour!
Tried to update to firefox-3.0.8|[VL6.0] under gslapt , but failed., it prompted as:
"firefox: Depends: libxcb >= 1.1.91-i486-2vl60"

which means missing dependencies., only found "libxcb-1.1.91" packages under VL6.0 testing tree, should I risk updating libxcd in VL6.0 testing tree?
     
 a bien tot

 Sad Blast. I thought my build environment was clean....

You could try slapt-get with the --ignore-dep option. I think it will work without problems with the older version. I'll have to see if I can track this and rebuild once I get the build environment clean again.  Sorry about that. Can you let us know if it works when forced to install?

I wouldn't recommend enabling testing at this point, unless you want to do some testing. The x section is in something of a state of flux at present, and you may end up with more than you bargain for.

 Grin Ok, please ignore the above. I've checked and (I hope!) cleaned my build environment, rebuilt it with the package from the original iso, and put it back up. So, if you use Gslapt sometime in the next few hours, I hope you will get it without any dep problems. Please let us know if there are any other problems.....

paul.

« Last Edit: April 02, 2009, 04:41:19 am by toothandnail » Logged
vincent2
Vectorite
***
Posts: 388


« Reply #14 on: April 02, 2009, 07:05:48 am »

ye ! run gslapt again Firefox got updated nicely Smiley

Merci!
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!