VectorLinux
September 20, 2014, 11:39:12 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Using PC cards with VL 5.8 SOHO  (Read 1179 times)
w2gnd
Member
*
Posts: 31


« on: March 30, 2009, 12:52:17 pm »

Hello,

I have  VL 5.8 SOHO loaded on a Micronics TransPort GX3 notebook and I am trying to get it to recognize my PC cards (PCMCIA memory type). 

Using VASM, I click on "adding a mount point" and the card is not listed.  Using KinfoCenter, the card is not listed under storage devices.  Under PCMCIA, KinfoCenter  indicates no controllers are installed.  Under PCI, however, the list of devices includes a Texas Instruments PCI1420 CardBus Bridge.

According to Gslapt, pcmciautils-cs are installed. 

Is there anything I can do to "turn on" the PC storage card function?

Thanks!   Bob
Logged
bigpaws
Vectorian
****
Posts: 1850


« Reply #1 on: March 30, 2009, 03:07:14 pm »

Open a console su to and enter root password

Now try this:

/etc/rc.d/rc.pcmcia start

Then check for your devices.

If that works then check to see of VASM has a setting to enable pcmcia.

Should that not be the case then add the above line to /etc/rc.d/rc.local

Bigpaws
Logged
w2gnd
Member
*
Posts: 31


« Reply #2 on: March 30, 2009, 03:51:16 pm »

Bigpaws,

I tried the command you gave me at root in a console.  I got this:

vector:/~
root:# /etc/rc.d/rc.pcmcia start
-bash: /etc/rc.d/rc.pcmcia: Permission denied

I thought that was strange since I was in "root".

Just for the heck of it, I added the line you gave me at the end of your message to see if anything happened.  Its like the line wasn't there.................Nothing.  I checked VASM for a way to enable PCMCIA support but didn't see anything.
Logged
bigpaws
Vectorian
****
Posts: 1850


« Reply #3 on: March 30, 2009, 03:55:29 pm »

I am guessing that the file is not executeable.

Open a terminal as root and type

chmod +x /etc/rc.d/rc.pcmcia

then give the above commands a shot.

Bigpaws
Logged
w2gnd
Member
*
Posts: 31


« Reply #4 on: March 30, 2009, 04:08:28 pm »

OK, we're making progress.....

After making that executable, I re-typed the line and got this:

root:# /etc/rc.d/rc.pcmcia start
Starting PCMCIA services:
  <Probing for PCIC: edit /etc/rc.d/rc.pcmcia>
cardmgr[4588]: no pcmcia driver in /proc/devices
vector:/~
root:#         

In my first post, I indicated that I thought there were drivers in "pcmcia-utils" which was listed in the packages in Gslapt.   What is my next step?                                 
Logged
w2gnd
Member
*
Posts: 31


« Reply #5 on: March 30, 2009, 04:14:37 pm »

Don't know if it matters but...........

The PC cards are SanDisk ATA 1.2GB memory cards.
Logged
bigpaws
Vectorian
****
Posts: 1850


« Reply #6 on: March 30, 2009, 07:41:18 pm »

It would be my thought that these devices should be seen as
a regular type disk.

Open a terminal and as root type:

fdisk -l

I believe you will see your cards, you can also look at dmesg. Another thing to
try would be to look at /var/log/messages and then insert the card and then
look at that file again. You should see something that changed. Post those
types of changes.

Bigpaws
Logged
w2gnd
Member
*
Posts: 31


« Reply #7 on: March 31, 2009, 06:01:33 pm »

OK,

fdisk -l gives a list of the hard drive partitions hda1, hda2, hda3, and hda4.  I typed dmesg and got nothing.  But when I remove and replace the card, I get this:

pccard: card ejected from slot 0
pccard: PCMCIA card inserted into slot 0
pcmcia: registering new device pcmcia0.0
ata2: PATA max PIO0 cmd 0x3100 ctl 0x310E bmdma 0x0 irq 3
scsi4 : pata_pcmcia
ata2.00: CFA, max PIO1, 2344608 sectors: LBA
ata2.00: ata2: dev 0 multi count 0
ata2.00: failed to set xfermode (err_mask=0x1)
ata2.00: disabled
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!