VectorLinux
November 25, 2014, 06:43:18 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: How do you change permissons for Chestnut Dialer ?  (Read 3480 times)
frank56
Member
*
Posts: 30


« on: March 30, 2009, 12:55:16 pm »

Chestnut dialer, what a great dialer! But I can only launch it from a terminal as root. I vaguely remember an easy way of changing permissions but perhaps I was dreaming. :-). So how do you change or set permissions for Chestnut dialer?. If someone can point me to a link or explain here, I sure would appreciate it. Frank
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3192



« Reply #1 on: March 30, 2009, 01:06:12 pm »

I've done it before by editing the sudoers list

WARNING: Be careful with this file. Not following these steps carefully could cause you serious problems

Code:
visudo
You'll be using vi... hit the "i" key until you see "INSERT" at the bottom of the terminal widow
navigate the file using the up,down,left,right keys
Find the line that says
Quote
Cmnd_Alias DIAL=
and add this entry to the end of the line
Quote
,/usr/bin/chestnut-dialer
notice the comma... do not miss the comma... follow the same formatting as the existing text on this line... you're just adding a new entry to this list.

After this, you hit the escape key "Esc" until the "INSERT" goes away
at this point, type this in your keyboard
Code:
:qt
that will save the changes and exit.
You can now execute chestnut dialer by calling the sudo command
Code:
sudo chestnut-dialer

HTH
Logged

overthere
Vectorian
****
Posts: 1281



« Reply #2 on: March 30, 2009, 03:15:15 pm »

there are various ways to do this

if you want to use the root account as user try /sbin/vsuper chestnut-dialer..you may add a new item to the menu or add a launcher to the bar

if you want to use the user account try as root in terminal chmod 666 /dev/modem..
this is session only.. for reboot add to /etc/rc.d/rc.local at the bottom
cheers
« Last Edit: March 30, 2009, 03:19:55 pm by overthere » Logged

Everything Is Relative
frank56
Member
*
Posts: 30


« Reply #3 on: March 30, 2009, 04:22:51 pm »

Thank's Moe and Overthere,

After entering visudo. The pertinent line reads in complete form: 

Cmd_Alias Dial=/user/bin/gkdial,/usr/x11r6/bin/x-isp

I'm guessing thats because on the initial install, I chose to "auto" ? configuire the first suggested dialer, X-isp. At any rate I havent made any intentional changes but it sure easy to screw up, I found out. I waited too long after I started and my screen saver kick in and I hit some letter key. and to make matters worse I close the window. The program warned me I had to programs running when I try to restart.
I followed the instructions to recover, I just hope I did it right. I think I may try Overthere suggestion, since it seems easier. I think I better wait for further instructions. Thanks Overthere, and Moe. Its always good to know there is more than one way of doing the same thing.


Subsequent edit about 10 minutes later. Overthere, Problem solved.. It must have taken me less than 5 minutes. I was going around in circles. I was adding for this session only. :-).  Newbies are supposed to stuff like that ...RIGHT?. Anyway Im not really a newbie, I'm 63. :-). but Thanks. Nice to just be Able to click on Chestnut menu. In windows one can create a short cut, but perhaps thats good for another thread?

Second edit...3/31/09. More on Visudo....Moe is right...Warning..be very carefull. I got locked out my dialer. If you do open visudo, do your viewing and or changes but dont leave it open. I did and my screensaver kicked in and I usually hit any key to wake it up and that generated the first problem code. I decided on the quick solution and re installed. Opening visudo, it seems like an incredibly usefull option or command, loaded with tons of options, I as a newbie would only try with call by call advice. Thanks Moe also for introducing me to how to enter visudo. This Problem was solved.
« Last Edit: March 31, 2009, 05:20:17 am by frank56 » Logged
overthere
Vectorian
****
Posts: 1281



« Reply #4 on: March 30, 2009, 06:24:43 pm »

sounds like you got it working ..if you want to add an icon to the desktop I think you just open the file manager and navigate to /usr/share/applications..right click the dialer and copy..then navigate back to /home /desktop and paste..it should show now on the desktop..I do not often use icons on the desktop but recall that as the process

if you like a launch button in the bar in xfce then right click the bar and add item..launcher... then add the icon of choice and the command..the button beside command allows you to navigate to /usr/bin and click chestnut-dialer and the icons are in /usr/share/pixmaps or /usr/share/icons..it is relatively easy but if this is not good help post back and I will be more specific..I am on another machine and it is easy to forget being a relative newbie like yourself
cheers
« Last Edit: March 30, 2009, 06:27:07 pm by overthere » Logged

Everything Is Relative
nitehawk
Vectorite
***
Posts: 155


Just me.


« Reply #5 on: March 31, 2009, 01:33:43 pm »

Great advice!  Also see:
http://forum.vectorlinux.com/index.php?topic=8811.0
Vector is such a nice distro,...don't you think?
Logged
overthere
Vectorian
****
Posts: 1281



« Reply #6 on: March 31, 2009, 07:47:38 pm »

Yes..and thanks for adding the link.. although I did not need to be root for the copy perhaps it is needed in other situations

cheers
Logged

Everything Is Relative
frank56
Member
*
Posts: 30


« Reply #7 on: April 03, 2009, 06:55:31 pm »

there are various ways to do this

if you want to use the root account as user try /sbin/vsuper chestnut-dialer..you may add a new item to the menu or add a launcher to the bar

if you want to use the user account try as root in terminal chmod 666 /dev/modem..
this is session only.. for reboot add to /etc/rc.d/rc.local at the bottom
cheers

Hi Overthere,  I thought I was done here, but chmod 666 /dev/modem works great. But I want to try the reboot option you mention on this post. The part "at the bottom" I don't understand, and also "add to /etc/rc.d etc. . Do I do all this in one sequence?  For example

chmod 666 /dev/modem /etc/rc.d/rc.local then hit enter ? If anyone understands what Overthere meant in case he is not available please post. Thanks, Frank
Logged
overthere
Vectorian
****
Posts: 1281



« Reply #8 on: April 03, 2009, 08:29:07 pm »

Hi..sorry...try going to the file manager as root and find /etc/rc.d..open and scrool down to rc.local ..right click and open in a text editor.(ie mousepad)..at the bottom is a section for adding things...type chmod 666 /dev/modem then save the file.

.in xfce there is a bar icon for the file manager and the little bar or tab beside it if clicked will allow you to click super file manager...you will have to enter your root password..or you can log out and log in as root.

hope that helps
cheers
« Last Edit: April 03, 2009, 09:40:52 pm by overthere » Logged

Everything Is Relative
frank56
Member
*
Posts: 30


« Reply #9 on: April 04, 2009, 01:54:01 am »

Overthere are you a Rocket Scientist? Of Linux that is. I was very careful at following your steps. Except I could only find one File system icon so I had to workaround that by logging on as root and opening Desktop File icon there. I got all sort of warnings as if i was walking on booby trap mine field so indeed I walked very soflty.  From there I followed step by step as you suggested. I tried launching before rebooting and got a no carrier message but the permissions denied message no longer displaying. I decided to reboot, and launched Chestnut Dialer with no glitches. Thanks, Overthere, really appreciate your help. Too bad I cant help you, but maybe I can help someone else later on.
Logged
overthere
Vectorian
****
Posts: 1281



« Reply #10 on: April 04, 2009, 06:38:53 am »

hehe..I think they call the rocket scientists of linux guru's. and I an NOT one by any streach of the imagination...but glad to be of help...

when you log in as root the warnings are for your protection..it is a good thing

I am sure you will find opportunity to help as you become familiar with your system

cheers

« Last Edit: April 04, 2009, 06:42:11 am by overthere » Logged

Everything Is Relative
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!